Placing MEP fitting along pipe not working


I am aware that there are numerous threads about this topic, and I think I have read them all. Nothing I try seems to be working for this very simple test. I have 1 pipe that I am trying to place fittings along by dividing up the curve into segments of a particular length.
I would need the fitting to be rotated and sized accordingly, but that can come later after I have worked out the placement of the families.
Can anyone assist me or let me know where my errors are?

Thank you!

I’m not familiar with that last node, but I would try setting everything to the same length by setting the lacnig to longest (and if that doesn’t solve it set the list level of the points input to 2)

I would also check if the pipe element is the right input type. I presume the node is asking for the curve that drives the pipe element.


Thanks for your response!
I have tried your suggestions previously with no luck unfortunately… It is my first time trying to use the MEPFittings node and I think the inputs require the structure to be quite specific. I am just struggling to get it to that point however…

Hi @Sigma
I think that the node doesn’t work as expected for multiple elements and points, you have to modify the python inside the custom node of @T_Pover . Check also the instance parameters of your fitting family. Cheers

Thanks very much Paris,

I ended up using the Tools.splitpipebypoints node in conjunction with the OOTB familyinstance.bypoint node to get all the placements, then just rotated all the fittings to match the line vector, worked quite nicely.
Thanks for your response.

Hi @Sigma,
It’s clever, but after the Mepfitting it still in the same system of the pipes or not (try use the TAB bottom to verify)? normally if you split the pipes the piping system will became divisible…

Hi Paris,

Yes that is something that i noticed, unfortunately it does not keep any of the system information, will have to find a way to resolve that… The MEP Fittings also get placed with no “Level” parameter at all, which is quite strange?

Hi @Sigma,
It’s not strange, familyinstance.bypoint node works as a expected, you have to modify the custom node as mentioned above (is not easy) to keep the piping system with all informations and use the appropriate family fitting to work with. In the forum there are a lot of posts of this issue.

Try removing the flatten node. The final node is expecting a list of points for every MEPCurve.


I have tried removing the list.flatten node, still does not work. I have 4 elements and 4 lists of points as per the requirements for the node I think?
I have also seen that thread, unfortunately no success there either.

Can you post an updated picture for reference?

Thank you =)