Place wall by corners coordinates

Hi!

How do you place a wall by its eight corners with coordinates?

Cheers, Pontus

Assuming it is a regular wall (a cuboid), you can use the available information to determine the and create a center line at the base of the wall and it’s height. Then use the Wall.ByCurveAndHeight node to create the wall.

Thank you Vikram_Subbaiah for your quick answer! I need to place the wall based soley on coordinates. As I have done with the rectangel, I wanna do with a wall instead:

Cheers

Hi @pontus.jakobsson ,
As @Vikram_Subbaiah said, you can model walls from your rectangle using WallByCurveandHeight Node. Just make sure to explode your rectangle in order to get the curves from it.

Hello Pontus, a sketch or something smiliar would have helped a lot. Have you got eight coordinates like this?

Thank you Mostafa_El_Ayoubi! It isn’t exactly what I am looking for, but definitely on the right way. Much better than I have achieved before.

Eina_Raknes, it is exactly as your picture shows. Eight points based on xyz-coordinates. And I would like to draw a wall between those eight points.

For example, I have 8 xyz-coordinates that a wall needs to be placed at:

  1. (0,0,0)

  2. (0,0,10)

  3. (10,0,10)

  4. (10,0,0)

  5. (10,2.5,0)

  6. (10,2.5,10)

  7. (0,2.5,10)

  8. (0,2.5,0)

This results in these eight points:

Is there a way to place a wall solely on these coordinates?

Appreciate all the help!

Here is definition based on my earlier suggestion …

WallPoints.dyn (15.1 KB)

Thank you Vikram_Subbaiah! I haven’t learned enough to understand what you meant in the first post, but this is exactly what I was looking for!

Thanks for all the reply, you guys are amazing!

There’s one error though that I’m getting. It can be because my lack of skill, but I post a picture here just in case anyone of you know what’s wrong:

Check if the units are consistent across Dynamo and Revit
For example, if in Dynamo you have 9,3,1…, then the Length unit setting in Revit should be meters.

Yep, that caused the error. When I changed the settings to meter, I’ve got a nice wall:

Thank you all again for the help!