Place multiple model groups in Revit

I’m trying to place multiple Revit groups through a dynamo script, but can’t get it to work as I like.

With the Tool.PlaceGroupAtpoint (from SteamNodes) I can place the first item of a list.
But when I’m trying to adjust anything like “sort list” or “get item at Index” the script fails.

It is essential for the script I would like to write next, because I would like to integrate a filtering and placement through the DataShapes UI.MultipleInputForm ++ form.

After searching online, including this forum, I suspect it has something to do with coding of the PlaceGroup node. And especially the “List.FirstItem” in the coding of the node.
But that is way out of my league unfortunately…

Hopefully anybody here can help me out!

(I placed the script for the Tool.PlaceGroupAtpoint ndoe in top of the *.png.
It has no further meaning than to illustrate the proces/ working for me)

Hey, would you mind posting an image of…

But when I’m trying to adjust anything like “sort list” or “get item at Index” the script fails.


At the moment I can’t Mark, I haven’t got acces to my work pc. I’ll fix it Monday.

FYI: the script doesn’t give a fault comment but just don’t work.

whenever you can :slight_smile: even if it just gives nulls it’s very helpful to see the inputs and their previews…

I get the same as you, looks like the python needs ammending in the node…

Thanks for testing Mark.
‘Glad’ to see you get the same result.

Unfortunately adjusting python is not my cup of tea.
You, or anyone else, knows how to fix the bug?

Or a workaround on how to place multiple groups after selecting ‘by index’?


Hi @ErwinVerh @Mark.Ackerley

Try using Tool.PlaceGroupAtpoint along with List.Combine node.

@Kulkul intriguing… Will try when I’m back at a PC on Monday… Thanks!

Mark, I tried to recreate your script. With the same result as you.
(ps. I had to replace the curly brackets you used with straight ones, probably something to do with my dynamo 2.0.1 version??)


After that I tried to integrate Kulkul’s tip about the list.combine node and secondly a list.GetItemAtIndex node.
But with both nodes I can’t get a working result, anyone can give me a pointer what I’m doing wrong or what is missing; since I’m fairly new to dynamo.


Thanks in advance,

Hi Erwin

Try to use the Tool.PlaceGroupAtPoint as your “comb” and then reverse the order of your “list” inputs :slight_smile:

Hi All,

Unfortunately I couldn’t get the list combine to work either, I had a look in the node and I can’t see the problem. It’s using a zip in the way that I would expect.

I copied the node structure into the main graph and it looks like it’s working, but it seems to get into an infinite loop? I tried adding a while loop, but it didn’t help…




I just couldn’t get the Tool.PlacegroupAtpoint node to work, despite your help… :(.
So I tried another way and went with the DynamoMEP node: Group.PlaceGroupInstance.

It took me some time, but I got it to work and even collaborate with the UI.MultipleInputForm++ Node (I love this one by the way :))

The only thing I now want/ need to incorporate is how to place model groups at levels…
One problem solved, only one to go :).

Thanks for your help guys, much appreciated!!!

1 Like

@Mark.Ackerley If you remove lacing from List.FilterBoolMask node and List.FirstItem node inside custom node it would fix: