Importing Multiple Revit Groups Using Dynamo

Hello, I am new to the Dynamo world & so far failing to create a basic script for adding revit groups into a model that are controlled with an excel file for setting the coordinates & rotation of the group in Revit.
I am wondering if anyone can help with the issue ofnot being able to add multiple Revit groups. I have 4 Revit groups & have set the coordinates & rotation in Excel, I am just struggling to make the individual groups work - when I list out each group & try to node from the “Item” to the “GroupName”, the result shows “Empty List”. However, when I node from the String of the “Element.Name” to the “GroupName” it selects the 1st group from the “Element.Name” list.
I have tried various “String” options but I cannot seem to make this work!
I am sure there is a very simple workaround, but as I stated I am new to Dynamo & the whole script writing format! I am using Dynamo 1.2 & Revit 2016.
I have also viewed various help topics on the Forum which have being very informative & helped me progress to where I am now.

Hi @andy.payton,
You are currently feeding a group name (string) to Tool.PlaceGroupAtPoint.
Edit : Just tried and you are right you need the group name. It seems to be working correctly:

Thank you Mostafa_El_Ayoubi for your quick response, I still keep getting the “Empty List” in the “Tool.Place.GroupAtPoint”, Is this because I have several groups? Have I created the correct workflow?

What you show in your screenshot looks fine to me! can you share a dummy revit file with just some of the groups in it?

Please let me know if you can open this link.

Hi @andy.payton

You can upload the file in Google Drive / Dropbox and share the link here.

1 Like

Yes it is opening.

Thank you for letting me know.
The Groups have been created as simple groups which I will edit up once I am able to use the script properly. I have attached a snapshot of the basic Excel document to be used, once I get the basics working I can adopt this to a larger site.

I had the same problem as you using your file. So I took a look inside the node and came up with the following modifications:

these modifications make the node handle list inputs better

1 Like

Thanks again for your quick response on this matter, it really is appreciated! This may sound like a daft question but are the “input” & “Output” code blocks as i cant find them in my library?

this is inside the custom node “Tool.PlaceGroupAtPoint” . You can open it by double clicking on it. Input and Output nodes will only apear in the node library if you’re in the custom node editting mode.

1 Like

Oh right I didnt realise I was supposed to be altering the “Tool.PlaceGroupAtPoint” node. I have edited the node as you have indicated but I am still getting “Empty List” when I run the script.

Have you tried disconnecting and reconnecting the inputs to the Tool.PlaceGroupAtPoint node after you changer it?

Yes I have tried disconnecting & reconnecting the nodes but it still does not work. I assume it is something to do with trying to operate multiple objects at once.

Old but useful unsolved conversation.

I had the same issue and managed to solve this by extracting the python script from the custom node and by reproducing a node structure similar to the custom node but in the main script.
It’s not the most elegant solution but it worked. Though I haven’t really understood what the problem with the custom node was…!

2020.12.07_Group place issue|690x193


A different perspective,