Parallel list-data flow, without cross products

Hi all,

I have written a definition containing three major actions:

  1. create view; 2) create view filter; 3) apply view filter to view

As input I am using a 2-item list for all 3 actions. (In future it should be 100)

What i want is that, as the list is flowing through the 3 actions, and output is used for input, everytime list item 1 is combined ONLY with other list item 1. This is what I cant get done.

In other words (more specified)

I am using the following list for input:
‘test part 1’
‘test part 2’

The ultimate goal is to create the following:
-a view called ‘test part 1’, which has a view filter applied to it called ‘test part 1’ , which has a view filter rule with ‘mark’-parameter value ‘test part 1’
-a view called ‘test part 2’, which has a view filter applied to it called ‘test part 2’ , which has a view filter rule with ‘mark’-parameter value ‘test part 2’

So, 1-1-1 and 2-2-2

The result of my current definition is that (a) two views are created properly and (b) two view filters are created. BUT… two (very similar) problems occur after that.

  1. BOTH Parameter Values ‘test part 1’ and ‘test part 2’ are applied to each view filter (see image below). I dont want that. At first I thought that this might be some crossproduct lacing issue, but i checked, and in both the Create Rule node and the Create Filter Node lacing is set to shortest.

  2. Same issue is happening when applying these view filters to their respective views. I awant to assign view filter ‘test part 1’ to view ‘test part 1’, but both view filters are applied (see image below).

How can I manage that the input is progressed in the following way
1-1-1
2-2-2

instead of

1-1+2-1+2
2-1+2-1+2

I hope you understand this way of formulating it :slight_smile:

Any thoughts by you guys? Much appreciated!

Screenshot of the definition below. I am using some nodes and workflow by archilab_thinkparametric’s course on creating view filters (link). Hope you can help me guys! Many thanks in advance.

5

2

Try setting the parameterValue input to level 1 on your ViewFilter.CreateRule node.
My other suggestion would be to try separating your parameterValue list into individual two sublists.

2 Likes

that worked! nice :slight_smile:

BUT … the same thing doesnt seem to work on applying the view filters. I’ve tried the same things, playing with levels / seperating list into sublistst, but doesnt work out. However I feel like it has to be something similar…

Any ideas on making this work?

Also attached dyf file just in case.

3

CREATE VIEWS FOR PARTS .dyn (37.4 KB)

Try chopping your view list as well.

1 Like

I’ve got it. Thanks a lot @Nick_Boyts.

I had tried that before, but it didn’t work. However I had not noticed that the two chopped list were on different levels. One was on L4, the other on L3. After using L3 on both lists it worked. Nice! :slight_smile:

Thanks again very much!

Always be on the lookout for matching list structure :wink: