Packages for MongoDB?

Hi, I would like to know if there were any packages to connect MongoDB

I’m not aware of any.
You could most likely use an ODBC connection from Dynamo (you’d need the MongoDB drivers)


In the upcoming release of Aectech Dynamo package, there will be a set of nodes that allows user to connect mongodb with dynamo! Stay tune for that release!


When will the new version with mongo packages be available?

Hi @giacomoamico,

we project it to be released in the Q2 of 2021.

Hi @stillgotme
I’ve downloaded the Aectech dynamo package and I have my mongoClient connected locally through mongoshell but in dyanmo mongoClient returns null.

How can I connect my mongoClient to the package ? please help me, I’d be gratefull.

Thank you

The Slingshot package with a Mongo ODBC connection would probably work

Hi @khaoulakanna10 ,

  1. First you will need to configure your client settings through the MongoConfig tab:


  2. After relevant information had been keyed in, you can then use the GetDB() method to retrieve its DB and use the general nodes to get all the items in the DB:

Edit: If your DB are still loading, do give it sometime to retrieve the information. Otherwise the nodes will be show null

Hey @stillgotme
Thank you for you reply;
but I keep getting “MongoDB.Driver.MongoConfigurationException: The connection string is not valid” when I insert

What driver does this package use ? how does the cluster address looks like ?

I got this error

Hi there, this means either your cluster address is wrong or your db name is wrong. you will need to double check if your user name and password is correct too.

Hi @stillgotme,
I’ve checked it multiple time, but you know cluster address differs based on the driver (python, .NET, NODEJS…), so which one does the package uses ?

Thank you so much.

we uses .NET. you might wanna stick to .NET

is this a cloud or local Mongo instance ?
I’d guess permissions/security might be the issue

it’s mongodb Atlas cloud that I’m trying to connect to.

The cluster address should be just “” instead of the whole cluster address given by the mongodb drivers.