Package paths on server not working for some users

Hello, I was hoping you could help me with a little IT issue. today I tried to update 2 of my users and they are only getting a small amount of the packages in the folder that I point the package paths location to. They are missing all of the ones with the .dll files in it. Meaning the important packages like lunch box and clockwork. I thought I fixed this issue by importing the .dlls manually and all of my other users have access to all of the same packages as me except for these two. Does anyone have any idea what the problem might be then? Is this an IT thing? a VPN settings thing? btw we are all on VMs. Thanks!

They probably have the same packages locally on C. Remove all the packages from their Roaming folder and the issue should clear up.

1 Like

@mix It’s a good thing you threw in the “btw we are all on VMs” portion. We are currently working on the same problem with graphic enhanced passthrough VMs. As far as it seems, there is a signing issue with .dll files in that environment. We are still trying to track it down to find an answer.

If you check log files when opening locally vs. through your VM (if you can test locally), I would imagine you would see every package that contains a .dll looks something like:

2017-12-19 21:05:37Z : Exception when attempting to load package from 
2017-12-19 21:05:37Z : System.IO.FileLoadException: Could not load file or assembly 
'file://\\servername\Dynamo\1.3.1\\bin\Archi-lab_Grimshaw.dll' or one of its 
Operation is not supported. (Exception from HRESULT: 0x80131515)

Sorry I don’t have a better answer for the time being.

thanks for working on this issue Kraftwerk15!
@Thomas_Mahon I checked all there packages on there C drive, they didnt have anything in there. So thats not the cause. I unloaded all the package directories except for the right one. Still no dice. :confused:
@kraftwerk15 But if if that is the case, then why would it work on everyones VM except 2 peoples?

Are you pulling from a network location for all packages or are you mirroring packages to each location? When you were updating to two specific users, what were you updating for them? Dynamo? OS? VM?

The packages all live in the same folder on the same network location. Recently we just switched over to a new server. All I was doing was redirecting their package path to the new server location. It worked on everyone but 2 people. Some of the packages came in from that location, but not all.

Edit: So in other words I have most of the people with 100% of the packages and 2 people with about 50% of the packages.
But incidently those are the 2 people that need my scripts the most. :confused:

Are those two users part of the same group policy and have permissions to the folder? Do they have read access or read/write?

is the network location a trusted site in each VM?

Is the drive the packages live on bigger than 1TB?

Looks like I fixed one of them. It appears to be a permissions issue

(post withdrawn by author, will be automatically deleted in 1 hour unless flagged)

hi mix how did you fix…

I believe the issue was the users did not have read/write permission to the folder that I had the packages in. Once I got them permission, it worked.