Packages on Local Network

Hello all,

I am trying to save packages on my firms servers for distribution throughout the office. I know there are lots of posts on this but I think I have ran into a unique problem and I am wondering if anyone else has had the same happen or can shed some light.

I had all of the packages on my computer working fine. I moved them to the server for all to use. After I did this all the packages with “.dll” files did not show up (seems fairly typical). After talking with IT they upgraded my account to have admin access and all of the Packages showed up. They then set my account back to its original setting and I still have access to all of the Packages. We tried this on another computer and same thing.

Basic user rights: no Packages that contain .dll
User upgraded to admin: all Packages
User downgraded back to basic rights: all Packages still show

We have over 100 computers in the office and cannot upgrade and down grade every single one of them. Do any of you know what might be happening through this possess that is allowing the Packages to show?

Dynamo 1.3.1.1736

Thank you for any help you can provide,
Steven

You should have permanent “administrative” credentials for the specific network folder you put your dynamo things in, or get a special account you use when you copy things on the server.
It should be so that the system prevents for malfunctions. It should be restricted to “users” to put dll (exe, com, msi, etc.) files on the network in general.

@erfajo,

Thank your for the response. I should have been more clear about that. I have full access to read and wright to this folder location. My access to this folder did not change through this process. All so everything was set back exactly the same way but somehow I am still able to see the Packages.

that was strange…

thanks for the enlightenment. I will be aware of this if i should end up in a similar situation :slight_smile:

Yes it is a very strange one.

It was a while back but I recall an issue with our networked packages being moved, which resulted in the packages being written to a read only location, which allowed me to see some but not all nodes/packages, and locked me out of using graphs which previously worked when they were on the other network location (pinwheel for 20 minutes and then crash). New users were able to see some but not all of them as well, and old graphs wicked up as well.

Eventually we modified the path to read/write for everyone, but pre-migration users still had issues. This was fixed by removing the local path folder and ensuring Dynamo only looks to the network drive for packages, and then restarting Dynamo. Changing your account to a full admin could have cleared the cache for what Dynamo loads at start, effectively telling it to to look at the network instead of telling it to ‘load these dll files from these locations’ when you start, effectively doing what I did but more efficiently.

As a first step towards troubleshooting the resolution, try a new account with typical access and see if that sees all packages and nodes. Watch Ladybug closely as I recall it had additional issues with the network.

1 Like

Thanks Jacob,

It now seems to be working on other computers as well. I did copy all of the packages from my computer onto the network. I guess it would be best practice to delete all packages from ones local drive and then change the path and re-download. This way you have all fresh packages that were meant for that location.

I did my first test without Ladybug installed and all packages showed on other computer. I went back to mine and installed ladybug and it came through fine.

Thank you for your input,
Steven

1 Like

@JacobSmall

I have issues aswell since 1.3.1.
What do you have in place as to protect your working graphs?

Marcel

Frequent backups and manual monitoring. This is aided by the fact that most users won’t actually code or even wire nodes so Dynamo player is the only use for most users, so no need to worry about stuff getting broken often. In fact the only times stuff has ‘broken’ has been when the gate keepers tried to lock things down more or migrated to a new directory. That time I was dynamoless for like 10 hours and I almost died when I had to do bulk changes manually while it was sorted out.

1 Like

@JacobSmall

It seems to be solved now.

Marcel

Well we haven’t had any chance to test that yet (v1.2.1 here) but this is good to know.

Edit:
after letting my computer be turned off for the night it seams to be working again. sorry for the false alarm.

Hello all,
I just went to go use Dynamo today and all of my packages with .dll files are gone again. I have been using it almost every day for the past two week and everything has been working fine.

I am in the process of contacting my firms IT department to see if anything was changed over the week but to my knowledge nothing was. I can confirm Dynamo and Revit have not change but something on the network could have.

I have made the package network path trusted on my computer to see if that would work but got nothing. (Follow github link above to for instruction on this)

Any incite on why they would be working and then not working?