Linking dll package paths to a sever

Hi, below is what i sent my IT guy to help but maybe someone on here knows something that could help me.

Can you assist with this? Ill do my best to explain. Simply I’m struggling to link paths of an application extra files (things that are constantly updated I need to manage from one place) to the server so I can manage everyone from one folder. However, I think .dll files are struggling to read with the program on the server. Permissions are read/write for everyone. Not sure if it’s the program or something you can help with. The files will work when there in the local path but not the added server path. Previously packages had separate files that worked linking with the server but now the files are stored in the .dll file I think.

The application will show the packages as installed but not in the library side bar of the application. If it’s a package not using the dll files it will show up however.

Below just shows where you add the other links in the application. Changing the order of the paths doesn’t help.

Be great to get this to work as there is a ton of helpful things people are missing out on without this set up.

Remove all of the packages form the C drive location - it may be loading differing versions which causes some issues. Also, is the R drive a standard windows network drive or is there any kind of cloud mirroring solution going on (the cloud mirroring can break a lot of stuff).

R drive is a standard internal windows sever. Tried removing everything from the C drive.

hmmmm… try swapping the order and then restart. If that doesn’t help (getting to the straw grasping point here) try mapping via UNC.

Do you have any other packages on the drive that don’t have DLLs in them?

Ive tried that. Just been testing with those two packages. Ill google mapping via UNC and see what thats all about. Thanks :slight_smile:

1 Like

We kind of failed with the same practice. If you google it up there is already a few topic about the same. It’s just not working as it should. Also we made IT to deploy dynamo settings to everyone but the default path kept added back automatically.

One other way is to have a Group Policy to copy all files from the given folder to users default path. Packages are small so it is not drawing a huge network traffic in general.

If we create any dynamo tool that could be extensively used by anyone we take the python script out from the custom nodes and paste it into the script. This way they don’t need all kind of package. archilab and the 1-2 other dll based package getting deployed.

Hi @vanman @daninet

Close all Revit Applications and do these settings in internet explorer it should work for you:

Restart your PC. Open Revit and see the magic :slight_smile:

4 Likes

hes a guru, thanks Kulkul

1 Like

@Kulkul - can you explain why that wizardry works?

1 Like

Read this https://superuser.com/questions/44503/how-do-i-tell-windows-7-to-trust-a-particular-network-location

1 Like