Package manager won’t connect


I’m having the same issues as everyone here. I’v updated from Revit 2018 to 2018.3 so the security fix won’t install as it is the latest version. The updates for ‘Revit Personal Accelerator Security Fix for Windows 7/8/8.1 (.Net 4.5.2) – version’ and ‘Autodesk Licensing Service’ have also been installed but with no joy. I dropped the firewall temporarily to see if there was a block but the same result as above. My Dynamo versions are for both Core and Revit.

Are there any other solutions to this? Thank you.


Have you restarted since the install? Stupid question but I’ve had this come up in the last week.

If so please post:

  • What version and build number you see in ‘about’ for Revit 2018
  • What version info you see in ‘about’ flr Dynamo for Revit
  • The complete Revit journal and Dynamo log file from a clean session (start a new Revit session, then start a new Revit file, launch Dynamo for Revit, and attempt to connect to package manager, let it fail, close Dynamo, close Revit).

Hi Jacob,

Thank you for your swift response. I have indeed restarted the machine but with no progress.

  • My Revit version is:

-My Dynamo versions are: for both Core and Revit.

-My .txt files are attached for both the Revit Journal and Dynamo log file.

Thanks for your help.


journal.0543.txt (174.9 KB) dynamoLog_1261b7f5-0ed1-4e56-a581-3460df70fa8e.txt (2.8 KB)

update Dynamo to 1.3.4 as well.

Thank you Michael. This has solved the problem.

1 Like