Object.ByGeometry returns null

Hello everyone!

I have been exploring Dynamo for Civil 2020 (Update 2) lately and creating AutoCAD objects from Dynamo went smoothly. But since recently node Object.ByGeometry returns only null value despite no other errors in workflow and in .dwg file nothing changes. If I create Solid in some other way (Solid.ByLoft…) the result is the same.

I reinstalled Dynamo via Autodesk Uninstall Tool/ Desktop App but it does not resolve the issue.

I attached a simple cube workflow.

Thank you for suggestions!

[cube.dyn|attachment]cube.dyn (78.6 KB)

1 Like

Hi @MatevzB

Block should be ModelSpace:

Hello @Kulkul,

I changed Block to the ModelSpace but it does not resolve the issue.

Looks good to me:

Which version of Civil3D are you using?

Until recently it worked for me to.

I am using Civil 3D 2020.3, Dynamo Civil 3D 2.4.1 (all of them should be up to date).

Try running on new C3D template.

I tried running it on a several other templates that come with Civil but none of them worked…

Try a layer which exists, and try using another methof to create your cuboid (cuboid.bylengths, or extrude a rectangle).

Try Uninstalling C3d and install back again.

Uninstalling C3D and installing it again resolved the issue.

I had this same error before.
Tested on 2 PCs, one did work, but on the other I got nulls trying to create Solids.
I could create 2d curves, but not solids.

I too have just experienced this issue. It was working then all of a sudden returns null. Have uninstalled C3D and dynamo and reinstalled with no joy

Would you be able to run through your exact uninstall steps ?

I used Autodesk Uninstall Tool and unistalled all Civil 3D/Autodesk related products. For instalation I used Autodesk Desktop App.

I followed the exact same steps apart from removing some of the extra files under AppData which may be the solution to my problem as running C3D as another user solves the issue after an uninstall. Testing just now

@elliotgr2010 Out of curiosity, what operating system are you using?

Win10 with the latest update at the time. I actually created a new thread for this issue as creating Dynamo solids from AutoCAD solids was resulting in a similar issue. Deleting my user profile from the local machine solved my issue.