Lunchbox Structural Framing collector


Has anyone succesfully used the Lunchbox Structural Framing collector, and might be able to see, what I am doing wrong. I have used the Wall and Floor collectors, so I understand the general concept.

In the example on they have used the ‘Structural Framing Types’ drop down menu - but this returns null in my case.

I have tried most combinations of family, family name, family type etc. both in element format and as strings, so I am rather stuck now.

Hi @tmha

You should write family name and connect to FamilyName input currently your feeding family types to it. Cheers!

Yeah that seems to be the obvious choice, but unfortunately that doesn’t work to well for me either - but I could be doing it wrong. I’ve tried picking it out as a family parameter as well.

Cheers though!

Could you list me down these items:

  • Revit Version

  • Dynamo Version

  • Lunchbox package version

Currently I’m using

  • Revit 2018
  • Dynamo
  • Lunchbox 1.3 (I think)

I could try a different combination, if you think there’s a mismatch. I can see now that Lunchbox say built for Revit 2017.

Acutally, I just tried in Revit 2017 , and it works with the combination of my first picture (Structural Framing Types).

@tmha If you go inside custom node and change line 50 to if faminst.Symbol.Family.Name == UnwrapElement(famname): inside python then you should be fine.

And here is another way if you like to get using OOTB nodes:

Unfortunately it still doesn’t work, I triede restarting dynamo. It seems that it does not agree with Revit 2018.
Though the output has changed to ‘Empty list’ now.

I need both elements, curves and structural materials - but I have started collecting them seperately (similarly to what you’ve shown in the other example), it would just have been easier to repeat the same work flow as I’ve used for the other element types.

Mmm… Pretty strange :thinking: it works for me in both Revit 2017 and 2018 version. Never mind Run this file ForTina.dyn (7.2 KB)

I think I might have figured out, where the problem is. There has been incorporated new company standard families in our templates, when we upgraded from 2017 to 2018 - so you’re right, it doesn’t have anything to do with the Revit version. I can see that I can get some of the functions to work if I import a generic steel beam.
I think it might be our custom structural materials which don’t fit into the script, but I’ll have to test that out. When I run your script on one of our families, it returns an error saying that ‘material’ is not defined.

Thank you for all your help though.

@tmha Please mark the post as solved. You’re welcome!