Louver Adaptive Component By Point Error

Hey, Is anyone able to help me figure out what am I doing wrong here? Everything seems to work just fine until I use the “Adaptive Component By Point”. I am trying to generate louvers in Revit for a building facade that I can manipulate, but somehow I keep getting an error, see below:

Hey, did you try putting the adaptive component by points input to level 2?




The list structure is actually right here, as the node expects list of lists. I’m wondering why you set it to cross product though?

Have you checked if you have any nulls in the the points list?

Yes, it didn’t change anything unfortunately. :confused:

because when I set it to “Auto” it did the following:

I didn’t mean the geometry.intersect node. I meant the AdaptiveComponents.ByPoints :slightly_smiling_face:.

Did you check your List.Transpose for null values?

No real reason, I was just testing different settings to figure out where I could’ve gone wrong. It was giving me Error when it was set to Auto previously.No, I checked the Transpose.List ,it seems fine. Could it be the family itself by any chance?

Alright :slight_smile:

Can you upload the dyn and the family for testing?

I think AdapitiveComponent.ByPoint needs nested lists. e.g. [[list of comp1 points],[list of comp2 points]] but for single component creation it would be [[list of points]]. so just add a list.create before your adaptivecomp node and it should work

Feels like the family itself, or points which are too close to work with your geometry.

Note the list structure on my points matches the structure you have in one of your previous posts.


Martin, I attached the family & Dynamo file here.

Standard Louver2.rfa (372 KB) Louvers Test.dyn (28.0 KB)

Thank you!! It worked I needed to flatten my list! :smiley:

Had it worked. Please mark the solution so others can learn from this post in the future. :slight_smile: