Link Revit model in current project

Hi I am trying to link revit model in my current project but it is giving me error as below.

I am not able to find the link instance.

Please help me out for this.

…try inbetween the node “file from path” ?

Hi @Draxl_Andreas if I use that then the same error

can you open the node “work”(right click) ?
Is there a python script in?
which package do you use?

Yes I am using the node from Morpheus package.

i got it the script searchs for a list []

KR

Andreas
2021-12-16_12h08_47

Hay @Draxl_Andreas Still the same error

you do also not selfreferencing the project?

You mean ? I am not getting your point

some kind of link error i mean. when link the opend project

Nope, I am trying to link my models in the current project. Here I am sharing the file,

Please let me know why I am getting this error.

Link Model to specified coordinates.dyn (13.3 KB)

Hi @shashank.baganeACM if you check that last Exception message, it is telling you that both host and link models do not share the same coordinates, try using the OriginToOrigin one instead or fix the shared coordinates among your files before using the SharedCoordinates node:


Note that with your method the file(link) is linked and loaded in your file(host) but it needs an instance of the file(link) within the host file.

4 Likes

Hi @tradelie Please help me out. Even after I am trying to use the origin to origin node the same error I am facing. But If I check the revit links in the project browser then only one model getting linked into the current project.

image

When I try to link any model then it will automatically create instance right ? So why I am still facing the same issue ?

@tradelie Could you please explain what does that statement in the output mean ?

Hi @shashank.baganeACM …have your tried these amazing nodes here from DynaMEP…probably it could help…

2 Likes

Hi @sovitek I am not finding the node LinkedElement.Insert in the DynaMEP package.

Can you please confirm me the node from which have you used ? I can only find the node LinkOptions

So Can you please tell me ?

1 Like

perhaps you need upgrade the package…here is my version…

May be I am using older version of dynamo. Because of that I am finding any nodes here in my library is it if I am not wrong ?

image

Which version of DynaMEP package should I use that is compatible with 2020 revit Dynamo version with as shown in the snip ? Could You please tell me so that I will get it installed that version by manual then.