Line Patterns in Revit different from those found by Dynamo

This is really weird.

  1. I run a routine to delete Line Patterns starting with “IMPORT”.
  2. Dynamo find them and says they are deleted.
  3. I look in Revit and they are still there!
  4. I run the Dynamo routine again, it finds no Line Patterns starting with “IMPORT”.

But they are still in the Revit project!

Also weird is that Dynamo is finding Line Patterns that are not listed in Revit.
An example are a whole lot starting with “1-”.


I unloaded all Revit links but it made no difference.

It is as if Dynamo is reading a different file.

Has anyone seen this behaviour before?

Can’t see where you are pulling the data from as you’ve only posted a small bit of your graph, but it may be that the method you’re using to pull the names isn’t showing the import prefix as that’s not technically part of the name. Try sorting your strings using a List.Sort node and see if you find a matching pattern to the values shown in Revit.

Maybe your Line-Patterns are inside a family

Did some more testing:

Delete ALL families from project and Purged, so it is not Line Patterns in families or links.

On closer inspection it looks like “IMPORT:” does not appear in the Line Pattern name in Dynamo so the Line Patterns that do have IMPORT: prefix appear without the prefix in Dynamo.

There must have been a change in Dynamo (or the Revit API) as it used to work. Indeed the Modelical node ‘DeleteLinePatterns’ no longer works either.

I’m using Revit 2019.2, Dynamo Core & Revit


The plot thickens…

Line Patterns beginning with “IMPORT-” are found (and can be deleted).

But Line Patterns beginning with “IMPORT:” do not have this prefix in Dynamo.

These Line Patterns are still in the project file after all CAD files have been removed.

Anyone know what they are?


Check families and object styles.