Level Creation not appearing in Revit document

Hi All,

I’m trying to create a script that can write levels to Revit from Excel. I pull the data from a spreadsheet with level names in column A and the elevations in Column B. I create the levels with this data, then create plan views using the created levels but nothing appears in the Revit document despite element ID’s being in the dynamo watch nodes. I’m using Revit 2016 if that helps. The view of the revit window only shows AHD and ground floor, both of which were already in the document


Showing the Watch nodes with the elements created as planned

Revit view showing that levels haven’t been created.

Most likely a Units issue
The Length Units in Revit are probably set to millimeters while the Units considered in Dynamo may be in meters. (or the other way round)
The levels are probably being created, but are either very close together (or very far apart).

Doesn’t appear to be the issue, using ZE (zoom extents) there aren’t any levels anywhere else in the document even after hiding the initial two.

Could you try to right-click a level, choose “select all instances > in entire project” and see how many items are selected? It might be possible that the levels are outside of the 2d view’s extents.

Hmm… it comes up saying there are 74 instances of it but i can’t find them in any of my elevations or sections. additionally, it should be creating floor plan views for each level and it hasn’t done so.

It appears to have created levels but not level markers that are visible in elevation view.

Yes, this sometimes happens in Revit with larger models - the levels are beyond the view’s scope. Try some of these solutions:

If they don’t show in any views, you’ll need to create a scope box.
Under your drafting tab is a tool called scope box, use it to draw a 3D
box completely around the extents of your model. Now in elevation add
another level (this will be temporary), right click and choose “select
all instances” go to the properties and there is a category called
extents. Where it says none, click and choose your scope box for the
drop down menu. Then click okay and your levels should now appear as
there extents have been adjusted to that of the scope box. You may
delete the scope box now if you have no further need for it.

For the floor plans, are you sure they’re not hidden somewhere by the project browser’s organization settings?

Yeah… I now feel stupid. I called the BIM manager over to help and he unchecked the scope crop in the view and they all appeared, and the floor plans were generated in a slightly weird place in the browser. Everything worked as expected. Thanks for helping anyway :slight_smile:

1 Like

@Henry_Jarvis1 glad I’m not the only one that does that hahaha :slight_smile: