Lacing Help

I’ve been trying to update values in revit from an excel spreadsheet, using dynamo.
What I want to do is go through a “properties” column on excel, and then go through multiple “data” columns, with each data column being the same size as the properties column. For each data column there’s a corresponding piece of equipment.

I’ve been looking up lacing and I’m assuming this will be part of the solution. I’ve changed my data to numbers so it’s easier for me to understand. When I have the following,


and have my properties and data blocks set to shortest lacing, and a + operator to cross product, this gives the correct outputs of {11, 22, 33}, {14, 25, 36}, {17, 28, 39}, {20, 31, 42}
Then when I keep the exact same lacing format, change my numbers back to my properties and data, and use a “SetParameterByName” block, it now has 48 outputs, rather than the above 12 when I use numbers.

Sorry if I haven’t explained myself well, new users to this forum can only upload 1 photo

Hard to see what the error is without the graph to look at. Can you try linking to an image elsewhere or replying to the post? Thanks

I’ve made some progress since my first post. Now my problem is I can’t seem to change multiple equipment properties at once.
Without the LoopWhile blocks connected, for the first AHU, the Space Type is changed to “a”, the Space Mechanical Ventilation Type is changed to “b”, and the Space Mechanical Heating Type is changed to “c”.
I want to do this for the rest of the 3 AHU’s, but have d, e, f, etc up to l

With the loops connected it always crashes. I’m assuming I’ve created in infinite loop or something, however I can’t see where. I’ve also tried connecting the “+1” block to the x side rather than the y shown in the photos below.

I’ve also tried directly connecting the “GetItemAtIndex” blocks to the “SetParameterByName” block and just leaving the right hand connection of the LoopWhile blocks empty @JacobSmall

@Petar_Penchev1 - I’m replying in here because new users have a max number of replies they can do.

The error bubble you see in the picture is from a previous test, possibly without the “ContinueWhile” box connected. I only connected the nodes to show how I’ve set it all up, if I ran the it as shown in the pictures above it would crash.

What I need to do is change the index in the “List.GetItemAtIndex” from 0 and go through til it finishes the list. If I put in the index as 0 it will output a, b, c. If I change it to 2, it will output g, h, i, which is correct. However it isn’t outputting the first index, updating the revit model and then increasing the index by 1.

What I was thinking the problem is, is it’s finishing the loop and then outputting? Do you think I should have the “SetParameterByName” inside the loop somewhere?

From the screenshot we can’t see what the error is. Please move the cursor on the error so we can see what it is. It could be wrong data type - for example the parameter should be string and you feed numbers, or similar. The parameter name could be not string and wrongly feeded, there are many errors , so please screenshot yours = )