Dynamo doesn't write to parameter

I’m trying to make Dynamo combine multiple parameters into one new text parameter.

We have used the excact same procedure for another revit family which worked fine, but when I try to do the same on this family it doesn’t work.

Everything looks fine in the script - when I look in the white text boxes under the nodes everything looks perfect.

What last step am I missing to make it write to the parameter? :slight_smile:

Klip%202

What is your input for the elements for the node?

Yeah I meant more what is the element input list haha :sweat_smile:

Ok, I’m not sure what that is? Not a big expert in Dynamo :slight_smile:

The output from your list.filterboolmask

Thanks. :smile:

I think you need to change your lacing to longest of the element.setparameterByName.

To change the lacing you need right click on the node and you will see a menu pop up were you can find the lacing options.

I think this will solve the problem and learning Dynamo is proces haha :wink:

It worked! Thank you so much for your help :smile:

Is it possible to explain, just shortly, what it actually means to change lacing? Now I know how to do it, but I don’t know what I’m doing or why :sweat_smile:

Your input for value was only one object and the input for the elements were more than one object. With setting on auto it will just stop at the first one because you gave him one value but with lacing to longest it will set a value for all the elements you will put in.

You have also lacing cross product and shortest if I were you I would play around with the lacing sometimes to find out how they really work. With this you can make your scripts much more complex!

1 Like

Thank you so much :slight_smile: It’s really appreciated

No problem at all! people always are willing to help me here so doing something back to people that also need help!:wink: