Issues with SAT import Spring Nodes

Hi everybody,

I have a very strange problem with importing SAT geometries with the help of Springs.FamilyInstance.ByGeometry node. It works in most of the cases, except this one:

It works for QuaderTest2.sat (3.5 KB) this file, but not for this: QuaderTest1.sat (624.2 KB)
Both files are export from AutoCAD.

The Springs.FamilyInstance.ByGeometry node tells me:

[0] Traceback (most recent call last):
File “”, line 102, in NewForm_background
AttributeError: ‘NoneType’ object has no attribute ‘get_Geometry’

I don’t have a clue why it work with one geometry, but not with the other? All basics are the same, except the geometry.

Does anyone has a clue how to solve this? Or at least a hint?
(Be careful, the sat files are on coordinates)

It seems that both Dynamo and Revit can’t handle the input geometry:

The geometry appears to be extremely far away from the internal origin. Have you tried bringing it in closer? Things are a bit better then, but still not perfect:

@Dimitar_Venkov, thank you for the quick response.

Even if I get the SAT file close to the origin QuaderTest.sat (624.3 KB) (as mentioned, the file is geo referenced) I have the same issue.

Somehow, the geometry is shown correctly on Dynamo, but there is nothing in Revit, except the temporary geometry.

Not sure why the node is failing for you. Are you on a recent version of the package? As you can see above, once I moved the geometry closer to the origin, the import worked fine for me in Revit 2017, with the exception of a few missing faces.

Seems like something about the way Revit handles sat files changed between 2017 and 2018, because the same file fails completely in 2018.

The background preview works because it first tessellates any geometry into a mesh and Revit is much better at rendering triangles than smooth geometry :confused:

This to me looks like a software limitation. Not sure what else you could try, other than meshing or simplifying the input geometry.

That is really odd. in 2017 I get the same results like you. And 2018 the Problem is still there…

Might be, I have to rethink the process of model creation in AutoCAD. Any hints?

Thank you very much so far!