Issue with Shared Parameter Names, same GUID but renamed

Hi, i have an issue with shared parameter names.

A year ago i was some shared parameter naming as the left hand, and when i try to remap them with the correct name the family keeps the old name but the API and dynamo read them fine…

How can i fix that?

I want the names of the right in dynamo “ACM_MAD_DIM_length” instead of “ACM_MEP_Length”


Sorry this node open the Shared Files with correct names.

But the incorrect names is inside the family… i know that was a bad a idea to rename a shared parameter… but didnt have time in the project to change that…

So at all, how can i achieve to read the correct name if its the same guid?


Those two should be with DIM_…


The parameter (type lenght) might be driving geometry, not some placeholder for text information.
So i guess its not possible without loosing model information (distroy your work)

So i have to create a new shared parameter file and map all with the old ones?

Maybe someone else has a bright idea, wait a few days and see what happens

Thanks @Marcel_Rijsmus i read some post of @erfajo but didnt find a solution for that. I know was a bad idea to rename the shared parameters and now when i try to edit an old family that used the same guid i cant replace them with the new name… :frowning:

maybe the GUID is just a placeholder for the name :slight_smile:

And what does it mean? Dont follow you

By the way its so strange because when i upload all the families in a new project they contains the good name… but when i edit them in the family editor… the name change again to the old one…

you are getting there :slight_smile:
the GUID leads you to the name

You could try and copy the Shared Parameter file off and manually edit the name to be what you want, then open the project and families and see what it gives you. The GUID is the tie between them, not the Name.

@SeanP hi Sean. That is exactly what i did. The shared parameter file. The parameter was named ACM_MEP_Height and i renamed it to ACM_MAD_DIM_Height and when i open an old family that used ACM_MEP_Height when i try to replace it with the new name the family keeps the old name… it is like a bug? Because when i drop the family in a new project the family have the parameters with new name… what i am missing here? Hope someone help me because its a lot of families. Thanks.

See if this post can she’d some light. Looks like some parameter work in the families may get you resolved with swapping between Family and Shared parameter.

Interesting. And there is the possibily having the txt with all shared parameters to replicate them in other txt with different guid? Then remap all the old parameters… didnt find a best solution. @Kulkul shared some workflow but dont know if it would works.

So I tried this and it appeared to work:

Phase I:

  1. Created New Shared Parameter named Test_1
  2. Created Project Parameter
  3. New Generic Model Family
  4. Length Parameter Test_1
  5. loaded Family Into Project
  6. Both Project and Family were Test_1

Phase II:

  1. Manually Renamed Shared Parameter to Test_2
  2. Started New Project WITHOUT Test_1 in it
  3. Created Project Parameter with Test_2
  4. Loaded Family with Test_1 into Project
  5. Family Parameter name is now Test_2
  6. Closed Family
  7. Edited Family from Project
  8. Family Shared Parameter is Now Test_2

There are several steps here, but I think most of this could be easily automated. In fact, I have shared a post in the past that deal with loading, editing, saving and reloading families before that may be a place to start.

I know there are other packages that have Family Tools in them as well.

1 Like

Really appreciate your try. Thanks Sean i will try it as well.

Just a question, to get the StorageType for a shared parameter how can i get it? i tried to that method but not luck with that.



Check this solution by @Konrad_K_Sobon:

Sorry i explained wrong the parameter value i want.

I want for example the values “PG_DATA” “PG_TEXT”

If you are looking for the Parameter Group, try this: