Issue: Annotation Tags created only in Dynamo, but not in Revit ( they disappear from Revit)

dynamo
revit
archi-lab

#1

Hello,
I have a strange problem with the project I am working on, so I hope you can help me.
Short explanation of the script:
I have a project with different furniture families in Revit and my dynamo script should create annotation tags for the elements of this families in particular view, sorted by tag types. For creating of the tags I use a slightly modified version of the node “Create Annotation Tag” from archi-lab so it can accept multiple tag types as input. The only significant difference is one for-loop


Issue:
When I run the script on a smaller project, where I have inserted a few furnitures just to test the functionality, everything works as expected.
see image (small project) below
The Problem appears, when the project is a lot bigger. I have a floor plan with around 1600 elements to be tagged and 6 different tag types. While the script is running the tags show up in Revit,
see image: big project_script running
but just before the script completes they disappear. At the end there are no tags to be found in Revit, but Dynamo shows that 1655 tags were created.
see image: big project_script completed
Do you guys have any idea what could be causing this illogical behavior? My only idea is, that some transaction doesn’t complete “correctly”, which breaks the storing of the tags in revit. I tested a lot of different things including a version of the script where I use the unmodified node from archi-lab 6 times (ones for every tag type),
see image: another version
but nothing changed.


#2


#3


#4


#5


#6

Can you show the inputs you are using for your Create Tags node? Are you tagging linked elements?
Since tags require very specific objects to be created properly any one of them could be the problem


#7

Hello Nick,

here are the inputs.


There should be nothing wrong with them, because everything works fine on smaller projects.

The elements are not linked.


#8

Can you try running your graph with just 2 tag types instead of all 6? It’s unlikely that the number of elements is causing the issue but we could at least try to narrow it down.

Or if you could post the RVT and graph that would help too.


#9

Hello Nick,

here is the graph. Unfortunately, it is not possible to post the RVT.
As you can see in the graph, I manipulate the elements a lot, before they reach the final node. At the end I get the location points, the elements and the tag types as input for the slightly modified archi-lab-node, which creates the tags. I made a lot of tests and you can find screenshots of the results under the link to my google drive below.
As mentioned before I run the graph on two projects to test, if it’s working, one big project and one, a lot smaller. For the big project the number of elements pro tag type is as follows:

  1. 947 elements
  2. 151 elements
  3. 410 elements
  4. 11 elements
  5. 312 elements
  6. 219 elements

This makes a total of 2050 elements to be tagged. And for the smaller project there are currently:

  1. 8 elements
  2. 3 elements
  3. 4 elements
  4. 1 element
  5. 3 elements
  6. 3 elements

The number of elements could be indeed causing the issue. I made some tests and let’s say I run the graph with just the first 2 tag types, as you suggested. This makes 947+151 = 1098 elements and it works as expected. If I choose the first 3 tag types, which makes a total of 947+151+410 = 1508 elements, no tags are created. If I run the graph with all tag types except the first one, everything works fine. It’s a total of 1103 elements. So, with around 1200-1300 and more elements, it doesn’t work.

I also tested out what happens, if I select all tag types and then run the graph multiple times. Before each run I deleted some elements. When the number of elements to be tagged went down to 1263, starting from 2050, the tags were created. Then I tried the same thing selecting only the first 3 tag types. Again, after multiple runs and deleting elements, the tags showed up in Revit, when there were only 1101 elements left. (See folder: Multiple Runs_Deleting Elements)

Then I tried to run the graph multiple times selecting each time only one tag type. The result was, that the tags for the first two were created correctly. This means I could see 947 + 151 = 1098 tags in revit. Then the third one failed. (see folder: Multiple Runs_Only One Tag Each Time)

But that was not always the case. One time also the third one succeeded. This means, that 1508 tags were created. Then the fourth one failed with only 11 elements more. I also tried to create the 1098 tags, then to save and close Revit and dynamo -> reopen them -> run the graph again with third tag type selected (succeeded: 1508 tags) -> then again, the fourth one failed. So, the closing of Revit didn’t help.

That’s why, I’m not sure, if the number of elements is the real reason causing the issue. Sometimes, after running the graph ones with the first tag type and then ones again with the second one, I got 1400 tags created instead of 1098, which is incorrect. Sometimes, when I select only one tag type, let’s say the first one, and then run the graph all 947 tags are created, but every tag is created 3 times. This means, I get 2841 tags in Revit and 947 tags in dynamo.

Sometimes I get HelixToolkit.Wpf.SharpDX- error message and need to close and reopen Revit and Dynamo. (See errors-folder)

And all this cases work fine with the smaller project (See some screenshots in folder: smallProject).

graph.dyn (42.3 KB)

https://drive.google.com/drive/folders/1fAOiZdJAKFZmyfiijCzlKhmLAmPTRBqj


#10

Sounds like it could be a memory issue. Do you have a machine with more memory you could test it on?

If it is indeed too many elements (not enough memory) you could try setting up your graph to take a selection input of which tag type to use and run it on Dynamo Player (if that’s an option).


#11

Thank you, Nick! I’m going to test it tomorrow on other mashine and see what happens.