Installing a Package


could someone explain step by step how to install a package? I download a package from the “Dynamo Packages Manager”. I downloaded LunchBox as an example. The downloaded file is a .zip file containing several folders (bin,dyf,extra) and a json file. Both the bin and the extra folders are empty. The dyf folder contains a bunch of .dyf files. I am guessing that these are the components. I drag them onto the Dynamo canvas and they load but if I restart Dynamo I don’t see them any more. Could someone explain what I am doing wrong or how should I actually load a plugin?



1 Like

Hello Miguel Rus,

I guess you downloaded Package from Website and not from Dynamo.

If you download Package from Dynamo then it will get downloaded to this location “C:\Users\chandar\AppData\Roaming\Dynamo.7\packages”

So whenever you load Dynamo it will get added to Library and you can drag them to canvas.

If you have downloaded Package from Website then put your "Lunch Box for Dynamo"folder to this location “C:\Users\chandar\AppData\Roaming\Dynamo.7\packages”

so that it will get picked-up by Dynamo on load.

Keep using Dynamo and share your experience by uploading your Packages!



1 Like

Hi Ritesh,

thank you. That did the trick.

  • Miguel



My package search doesn’t seem to work… nothing is found when I type in a search text… so I downloaded from the package manager site and I followed the instructions in this thread. It worked for the lunchbox package but now I am trying to install rhynamo and I get this message… any advice is helpful thanks . e

Exception when attempting to load package Rhynamo from C:\Users\my name here\AppData\Roaming\Dynamo.7\packages\rhynamo
System.BadImageFormatException: Could not load file or assembly ‘file:///C:\Users\my name here\AppData\Roaming\Dynamo.7\packages\rhynamo\bin\rhino3dmio_native.dll’ or one of its dependencies. The module was expected to contain an assembly manifest.

Hi all,

Is it possible to install a package in such a way that all user accounts on that machine could access it, as opposed to going to User profile?

I know this is a really late response, but I wanted to share in case others came across this thread. I have the same problem as Ethan. My package manager will not return any results. I believe it’s being blocked by my network at work. I too manually downloaded and installed packages and got a similar error. I discovered that Windows was blocking the dll files because they came from an outside computer. By right-clicking and opening the properties window, I was able to unblock the dll files and the packages started working fine.

If anyone knows what URL the package manager is trying to access, I would sure appreciate it so I could get it unblocked!

how can i download the package from dynamo not from website





SORTED! Fixed!


I have Dynamo 1.0 and I was able to install certain packages ( Bakery\BOP\guid tools\Rhythm\Slingshot! for Dynamo\spring nodes\SteamNodes)

However, for Bumblebee and for Archi-Lab, I tried all the solutions in all the posts and I tried manual install and automatic install, uninstall, reinstall, etc… Also couldn’t find the “UNBLOCK” option anywhere on any menu or sub-menu in the file property of the .dll even though I have access rights to most file properties.

The only thing that worked was to install OLDER PACKAGES from around Jun 2015. The 2016 Packages don’t install on my Dynamo 1.0 version.

Hope this helps.