Insert Annotation Family to Multiple Sheet

revit

#1

I am trying to place an annotation family on multiple sheets. I can place for that scrip but one by one. I try to connect Tool.GetRevitSelection but i failed. Maybe somebody can help me ? Totally i want to place family to several sheet, not all.


#2

You can use list of sheets as an input to place them on multiple sheets. Just need to find a way to filter the sheet list. And lacing to be longest for FamilyInstance.ByPointView.


#3

Hi Gozde,
I try to use your way, but if you check the code, something wrong. I don’t understand what happened.
I am using version of dynamo 1.3. Clockwork also 1.3 but its not working.


#4

Hi,
It’s probably the lacing - needs to be set to longest for the FamilyInstance.ByPointView.
(To set it to longest: Right click on the node>Lacing>Longest)


#5

My mistake. You are right. For now this filter enough for me. Thank you so much! Gozde :slight_smile:


#6

Hello,

I am new to dynamo!

The FamilyInstance.ByPointInView node is not compatible with my dynamo 1.3.2.0

two nodes are either outdated or not compatible with my dynamo version,

  1. Return List Or Dingle Value.dyf
  2. Turn Into List.dyf

Do you by any chance have an update on that?


#7

here is a screenshot of what I got


#8

here is another screenshot of the custom node editor with error messages.


#9

update archilab clockwork and dynamo to the most recent version

it solved in my case the same problem


#10

I did but it didn’t work to me!


#11

you need to update to dynamo 1.3.2.2480
and the most recent version off archilab and clockwork
and i think in my case i had to first install archilab
and after that all the other packages to solve this problem


#12

thanks Nico,
I did all updates but still not doing what i needed to do.


I created a new topic in this regard, its insert family into multiple sheets.


#13

By the way. I have revit 2018.2


#14

I tried it on Revit 2018.2, its doing the same thing as in the previous screenshot.

I’ve attached dyn and the family I want to insert.
I would appreciate if you try it and let me know if it works to you.

Thanks!

Insert Gutter in Sheets.dyn (4.4 KB)
00_Titleblock Gutter.rfa (288 KB)


#15

It works for me


#16

did you also restart the computer?


#17

interesting!!!

I’ll have to dig more into it.

Thank you for your help.


#18

Do you share the package with others?
Try:
Install it on your own computer
Sometimes we had issues with sharing the packages


#19

it did work :slight_smile: I had to updated archilab and clockwork again and it worked.

Thanks Nico


#20

:+1:
Glad I could have helped