Importing closed polysufaces

Hello! I am trying to look for a workflow between Rhino and Revit massing by importing solid geometry into conceptual mass and then use it further in the project.

I realized that there are some issues in translating closed polysurfaces from DS to Revit. In this example i did a model in Rhino by trimming some extrusions and then i joined everything into a solid (closed polysurface)

When i explode the solid, all the individual surfaces are translated well (background model) well but when i use Import Instance by Geometry or by Geometries some of the faces of the solid model are lost in the process. (close up model)

Everything seems ok in the DS environment but not in Revit I used both Rhynamo and Mantis Shrimp and had same results

With the “Import instance by Sat” there are no problems. Does anyone know about this and if there is a fix?


1 Like

Here i imported the exploded polysurfaces and i joined them in Dynamo but when i try again to import into Revit most of the surfaces are gone.

Got the same result with all the options from Rhynamo, Mantis Shrimp and String Nodes “Family Instance by Geometry”

Hi Constantin,

Did you try using “DirectShape.ByGeometry” node.

Polysurfaces are second class citizens in Dynamo. From your images, it looks like the faces form a closed entity. Have you tried converting them directly to a solid instead? You can use the “Solid.ByJoinedSurfaces” node to do that. You might have better luck with that.

Hi ! I tried both options. Unfortunately the "Solid by Joined Surfaces"doesn`t work even though it says its a solid. Very strange. The "DirectShapebyGeometry triangulates everything

1 Like

Hmm, that’s a pretty stubborn solid. Could you try running it through spring nodes’ “DirectShape.ByGeometry” node? It’s handled everything I throw at it so far.

Hi Dimitar, thanks for replying! I tried with DirectShape.ByGeometry but still couldn`t do it. I read that it uses a SAT import function. i had the same geometry exported as SAT and used the “ImportInstance.BySATFile” and it worked but it was scaled down in feet units. I put the geometry modelling process from Rhino : solid extrusion then trimed the top with a surface and joined all in a closed polysurface. I see u did a fillet of all the edges. Maybe thats why it worked for you?


Hi Constantin Eugen! I have the exactly same problem that you have. Did you discover how to solve it?? I really doesn’t want to bring it to revit as cause everything became triangled faces

I am still having very much the same problem. I really wish there was a node that imported into revit better as well!

1 Like