How to fix Invalid ParameterType-Error in Project.CreateProjectParameter

Hello,

I have some Issues with the Parametertype while creating a Projectparameter. Why is “Integer” an invalid Parametertype? I also tried the Select Parameter Type function, but it ends in the same Issues. I was already searching for this situation but couldn’t get some answer.

Greetings
Matthias

Hmm… I suspect that integer is ok, it’s your Group that looks wrong?

image

See if this helps? Add Shared parameters to some families (Orchid package) I’m not an expert, @Marcel_Rijsmus & @erfajo are :slight_smile:

Hope that helps,

Mark

@s74316
I would choose another name aswell
ElementId is an internal parameter name you dont want to mess with

1 Like

as @Mark.Ackerley says, the parameter group is not valid. There is not any group named “Other”, and the only group not staring with “PG_” is “Invalid”.

as @Marcel_Rijsmus notes, consider what you name your parameters.

1 Like

@Mark.Ackerley, @Marcel_Rijsmus, @erfajo
Thank you a lot for your answers. I changed the group name and it obviously works now. I couldn’t change the projectparametername cause I need it for other scripts. With Autodesk Dynamo I create schedules and then add the unique ElementID to them. I know that there is an internal parameter with the same name. I use my parameter to reference on the internal parameter.
Here is the other script:

I found this both parts in some forum posts. I will link them for the cause I find them. You maybe know some solutions, but I don’t want to waste your time.

1 Like