Hosted Floor Sleeve is placed at wrong elevation

I am new to Dynamo & am attempting to use Dynamo to place pipe sleeves for me wherever a pipe goes through a floor with a specific parameter value.
I searched through the forum & found a similar post by Jona titled “Insert pipe sleeve at wall intersection with rotation and size”, Jona happened to share the .dyn so I started with that.
At this point I have been able to get the correct size sleeves placed in the project but they are not inserting to the correct “Z” point.
If I use the FamilyInstance.ByPoint node the sleeves will be placed without any revit errors but to the wrong elevation.
When I use the node from Springs - Springs.HostedInstance.ByPoints the sleeves show up at the correct elevation but I get an error from Revit saying it “can’t cut instance out of host”
.dyn attached, I can share revit file too if needed, it is too large to attach
Thanks for any assistance

Pipe Penetrations Through Floor Piper.dyn (341.0 KB)

Please share a reduced Revit files (not the all file ) for testing.

from a quick look at your graph- I would ask if the sleeve is a floor hosted family ?

The fact that it can be inserted without a host suggests it is not- which might explain why Springs.HostedInstance.ByPoints can’t insert it


Thanks for the response.
See link to a small file containing only a couple floors, pipes & the sleeve family.

I tried using a couple different sleeve families, the one shown currently on the graph is a floor based sleeve & it is a pipe accessory. I tried using a different one that wasn’t floor based, but was plane hosted I believe, that one was a generic model & I got the same results.

Thanks for the response,