Hide a detail group in multiple views (Archi-lab)

Hey everyone!
I will really appreciate your help. I have a model with multiple plan views and I would like to hide a specific detail group in many views at the same time. I am using the archilab Views.HideElements in order to hide the detail group in a View Set. The output I am getting from the archilab node is false and no detail group is hidden.
Thanks in advance for any help you can provide!

@nitsanBCACP ,

you can hide it this way, BUT…

In general i would recommend to do it via a view-filter implemented in a view-template…

or even specify your view by the topic, that is implemented in the design representation (2D-Components)



Hi, @nitsanBCACP.

Made with Python, simple to hide/show attached groups with ShowAttachedDetailGroups from Revit API:
Show_attached_DetailGroup_.dyn (73.7 KB)
Fell free to ask for any changes.

Thank you @Draxl_Andreas and @Vladimir for your help. It is very appreciated!
In this specific case as I have many views that share the same view template, I would not want to assign new view template to some of the view due to a specific filter.
Also, the detail groups I would like to hide are not attached to any model group.
At least, after consulting a colleague of mine, I understood why the script I have made didn’t bring the desired result. Actually a detail group is not an “element” and that is the reason why they weren’t hidden. I have to “extract” all the members inside the desired detail group and place them in the “elements” input of the Views.HideElements node. :slightly_smiling_face:

So, you see Detail Group unchecked in this window?