Help With Querying Linked Revit Files for Shared Site Information

Hi Everyone,

I found a thread that describes exactly what I’m trying to do, Basically just trying to generate a report that shows if a linked document is set to shared coordinates. see link![Dynamo%20Script2|429x500

I downloaded the solved and completed script, but it contains a custom node. I cannot find the custom node to download, so I tried to create a script without it. The issue I’m running into is that I cannot retrieve the element ID from the RevitLinkInstance…

I’m not sure if there is a better way to go about this, any help would be great. Thanks in advance.

The script

Here is the python node


try Element.Id

Hi @burtonridr,

You don’t need to connect the python node to another node.
It’s independant because the script collects all Revit links in the project and emits the project location.


1 Like

Thanks for the response, I tried that and it looks like I got the element ID, which is awesome… but now the python script is not working…


Thanks for the response Alban,

I tried this route and the python script is not working…

Any ideas? Is the python script incorrect or have a bad line or something? I’m still very inexperienced with Python coding.

Can you show the error message (in yellow) above the python node ?

Here is a snip, thanks for the help.

This is the error with and without any input being attached to the node… The model I’m in should have all the links set to “not shared”. Is that why? I tried to run the script with one of the links being set to “Internal”, which I thought was the same? Any thoughts?


When aquiring coordinates, you do not have to rename your shared site, this is only a name which can be anything…that includes “Internal”

Try the dynamo graph in a test file with 2 or 3 linked revit files and see what happens.
There is maybe a problem with one of your links.

Any update on this? Sounds like I had more or less the exact same experience as you when trying to replicate this script. I attempted disconnecting the python node as Alban suggested but the Error on Line 36 continued to be an issue.

Edit: I was just able to fix the issue i was having. One of my links was not loaded. This was causing the error. Upon removing the Unloaded Link the script ran as intended.