Help with design script


#1

Hey all

I got this little gem from "HyunWoo Kim"s blog, its awesome. Allows any adaptive family to follow the site contours of any topography given any 2D path. Its been working really well for us, we have been using it to place Site hoarding (fences) to coordinate site works and logistics and its fantastic!

Unfortunately, it seems to not like working on any newer version of Dynamo past 7.4(ish) and our office has now upgraded to v9.0. Its only the code block in the middle of the definition that seems to not work, it just runs for ages and crashes or i have to force close Revit. It usually only takes like 5-10 secs to run. Heres the video he posted showing how it works (http://plevit1.blogspot.kr/2015/04/railing-on-topography.html)

And here is the definition Test Site Follow

 

Any help is appreciated


#2

Took a quick look at the script in the code block, I might be wrong, but doesn’t seem like the problem lies in there.


#3

Vikram

Did you manage to run the Definition? Any time i try in v9 or newer it just runs and runs and runs… and eventually crashes. Last week it was working perfectly fine in v7.

I’ve ran each part separately and all work as expected until i try and run the code block.

Have you any ideas? Maybe v9 uses slightly different code or something, im not sure?

 

Or even, have you or any one else got another way of 1) Selecting a 2D path (model lines) > 2) Dividing the path into an even number of points at “X” spacing’s > 3) Projecting these points onto a Topography?

Thanks


#4

Ensure that the entire model line is well below the lowest point of the topography.

Haven’t managed to run it as I’m missing the Custom Node and the Revit file (with relevant families)


#5

TopoToPolySurface There is the Custom node :slight_smile: teste site follow and there is the project file with the family loaded in “FarmFenceAC” ( has 2 types, “First” and “General”) I’m probably missing something obvious xD just cant seem to get it to run Thanks

 

EDIT, this has the correct Revit file in now


#6

Change your Revit project units to meters (something larger than mm) or increase the value of the variable Between Posts to correspond with the unit type


#7

I ran into the same problem a while back, and fixed it. Try the attached (Works in Revit 2015 and Dynamo 0.9).

I’m assuming you have the AC family already, if not just pipe up.

HyunuKims_FenceGenerator


#8

Vikram

Yip, as simple as the Units! Ive been pulling my hair out about this for a while now haha! Always something simple that gets overlooked!

Thanks very much for your help, much appreciated!! :slight_smile:

Sol, thanks for the file, Vikrams sorted mine so all is good again!