Getting Null values and 0 values dimensioning Columns in several views- GeniusLoci

Hi All,

Last couple of days I have been working on a script that will dimension the height and width of a column in specified views. (Top views and side views). Currently I am focussing on the Side view, Top view works quite fine as it is for now. I Am planning to combine these into 1 script later on, but for now I worked on these separately.

At the moment I got the height dimension to work on 2 out of 3 columns. For some reason, I couldn’t figure out why yet, the first column in the selection creates Null values in the script, hence it does not create dimensions for it. I have tried a couple of different lacing combinations too, but somehow the “Compound Edges References” Node gives out these Null values. The columns have all been created in the same way, they are from the same family just a different type.

For the 2 columns it does create dimensions it also creates dimensions on the edges of the column with the value of 0. I have read a couple of post were these dimensions were deleted after they were created. Ofcourse this is a working solution,

but I was wondering if it is possible to prevent this from happening at all. At this time I am thinking about filtering the references that are the same as other references and create a list that only consists of unique references.

I have attached the script and a custom Node I used to this post.
(The test project I am using is too big to upload, I’ll try to attach this later).

MT_Test02_MaatvoeringKolommen V1.5.dyn (77.1 KB)
AllocateSurfacesOfSolid.dyf (49.7 KB)

— Edit—
I created a WeTransfer link for now. The file is still to big…

Hope some of you could help me further with this script.
Thank you all in Advance.


Manon van der Tuuk

Dear, @Alban_de_Chasteigner, I have seen you comment and find solutions to a couple of related post. Any possibilty you could take a look at my script?