Auto Dimension missing in the view. (Wired. Only part of them)

I am creating dimensions by Dynamo and only part of the dimensions are not showing in the view, or anywhere. I tried to search for their element ids. but it shows “No good view could be found.”
All the other dimensions created by the same node are showing well, but only one of them is missing.

I am using Dynamo 1.3.4 and Revit 2019.

Please help me out if you got any ideas. THANK YOU!!!

Is there a particular reason you are using dynamo 1.3.4 for Revit 2019?

Yes. Too many nodes and packages are involved. It will be a lot of work to upgrade them.
Is this a problem for 1.3.4 or 2019?

I think anyone here would advice to use 2.0 if you are using revit 2018 or 2019. But that’s probably not the issue right now.

Could you show the other nodes attatched to the Dimension ByReferences node with the content or a watch node?

Thank you for the advice. We may think about changing it to 2.0, but probably not now.
Below is a screenshot of the input data.

Hi Janet,

My best bet would be a problem with your views input.
You are inputting 6 lines, 6 sets of 2 references and 4 views.

Can you confirm your views are correct?

I am not familiar with that node but this is my first impression. If anyone wants to correct me please feel free to do so.


Thank you so much! That’s what got wrong!
I reset the cycle of the views and get it right. Now it works as it supposed to.
Thank you again! :laughing:

1 Like

Haha I am glad I could help, no problem!

Would you please mark my comment as a solution to help others who run into a similar issue? :slight_smile:

1 Like

Hey Janet. Would you be willing to show your graph or share your script?