"Get Type Parameter" Node is not there


#1

yesterday I create a dynamo-script to export the parameter in Excel, all Parameter, the instance and the type.

tody i open the script to change anything, but now is the node “Get Type Parameter” not there. I search it on my PC, i cant find it :frowning:


#3

Why not use the built in nodes? (here is an example with set, but is the same with get)


Identity Data Parameters
#4

Thank you,

i don’t know why, but the Node was on my custom-folder on PC and not in the company-shared-folder. I fount it and copy them ( “archlab-Grimshaw”) to the Company-shared-folder - now the node is there.

First Step i need to write all parameter (Instance and type) of all placed doors in project in a excel-file.

Next step need to set the changed Parameter from the Excel-File. First i have to complete the big job “Door-List_Excel-File”

Thank you


#5

@Heinrich_Boldt
I found not all of the archlab-Grimshaw nodes were there in the latest build. I had to go back a few releases to find the exact node I was after.


#6

Thanks for a great thread!

I’m kinda new to Dynamo and this helped my a lot.
But I only have one question. How do I find the ‘Element.Type’ nod? (as Einar showed (element->Element))

I tried searching for it, but nothing came up.
Then I tried to install a package, ‘Clockwork for dynamo 0.7.x’ (read somewhere that it would help) - But still nothing!
(Only ‘Element->Type’ is now available)

How do I find the Element.Type? Do I need to install something? Is there any thread about this already?

Hope you know the answer :slight_smile:

Thanks in advance


#7

I have the same problem as a new user too :slight_smile: waiting for the experts reply


#8

It’s probably my fault or the node has been renamed. Search for ElementType. It’s under Revit > Elements > Element


#9

The ElementType node doesn’t exist before version 1.0.0.