GeometryColor.ByGeometryColor not updating properly


#1

Hi,

I’ve created a graph that places blocks around a plan in Dynamo, the block can be resized - they should display green and change to red when clashing.

(To change the graph you change the width and length sliders).

I use a filter list by bool mast to separate the blocks that clashes - this works fine when looking at the watch nodes, I then pass the two lists to the GeometryColor.ByGeometryColor nodes - this partically works, some update some don’t and others don’t change.

I can see no reason why as the info passed to the colour nodes is fine.

Is this a bug? Any ideas why this is happening?

Thanks.

Desk Analysis 07.dyn (234.3 KB)


#2

Have you tried ‘Freezing’ any upstream nodes that generate geometry previews? These can get in the way sometimes when trying to display colours.

Edit: Disable preview as per Jacobs post below.


#3

Frist off, don’t freeze nodes, but disable geometry preview for them This should be done for ALL nodes excepting the ‘GeometryColor’ nodes.

Second, your node which colors items Red is reading the contents of the watch node adjacent to the List.FilterByBoolMask node, not the ‘in’ value from the bool mask.

Third, you will be well served to spend some time neatening up your graph. Data is running from right to left, then left to right, then right to left again. Wires are criss-crossing all over the place in a way which makes reviewing your data flow rather difficult. Another adjustment would be to get away from using lists, working with the content and then disassembling lists for review (16 sliders, combined into two lists, calculated somewhere on the left, and then disassembled on the right into two separate lists). Instead, consider using single list of dictionaries, enabling you gathering results for each zone in sequence.

Lastly, you may want to look into Project Refinery for optimizing the slider values - manually dragging all 16 combinations into an optimized result will take a VERY long time, and stopping at ‘do we have a clash’ could be all the evaluation you really need. Feel free to reach out if you have questions on getting started with that.


#4

Oops, my bad, did mean preview, holiday brain down here :roll_eyes:


#5

Great - disabling the preview worked - thanks for your help!