Display.ByGeometryColor node seems to be missing?

dynamo

#1

Hi!

I am new to Dynamo and I am using Dynamo 2.0.1.
I am trying to set opacity to certain solids so I can see objects inside them.
The way to go about appears to be (looking in the Dynamo Primer) to assign a color to the solid using a GeometryColor node and then output that to a DIsplay.ByGeometryColor node.
However, I can’t find the Display.ByGeometryColor node.

Any guidance would be higly appreciated.


#2

Hi @mahir.ulker-kaustell,

The new name of the node is GeometryColor.ByGeometryColor.


#3

Hi @Alban_de_Chasteigner,

Thank for your fast reply!

My set of nodes look like this:

image

Then, what am I doing wrong?

/Mahir


#4

Sorry for the bad figure. I will try to fix it…


#5

This is better:


#6

It’s not possible to help you without the previews under the nodes and the error you get.


#7

Thank you for taking time with me here!

I do not get any error messages. The proble is that regardless of what color data I give in the color palette node, the solid is shown in the default grey color.


#8

Right click on nodes which create the preview prior to the GeometryColor.ByGeometryColor node, and disable the preview for them.


#9

I was making an example.
Do what @JacobSmall has written.


#10

Thank you both so much. @Alban_de_Chasteigner yes, this fixes my newbie problem.