Geometry intersection result in non joined curves

Hi guys,

I do run into an issue here… And I hope to get help.
I need to create a fadin patern along dome surfaces imported from Alias.
There are a few patches of surfaces.
To determinate my axes for the patern, I did create some flat lines with number sliders, all fine.
Then as it is not a flat surface, I want to get the lines on my surfaces…
In short, I did create planes along X axis, with my straight lines and then I did intersect them to get the curves to place my patern.

Here is my issue, from the intersection, when I do use my intersection result to place a point at segment length and start defining my space, I do have one segment per original Alias surface, see picture.
I would need one curve from each segment, so I tried to convert to polycurve but not working.

I would like to know if anyone has a solution to get from each “connected line” one single polycurve to work with.

I hope to get your help!


PS: I did try the group curves node, via the package, but it result in an empty list :frowning:

Hi @ClRo ,

Have you tried the “Group Curves” node from the package?

Hi @Daan

Thanks for your answer.
Yes I did, did not work.
I saw this solution a few times on the web before posting.

After hours of research, I did figure out why it was not working. I am new at parametric design, it might sounds stupid in a way :smile:

The result of my intersection in some areas was giving some points, not curve, that’s why I could not use the polycurve by joined curves…
So far from what I could see on the list, it is the first item and the last item, so I did drop those 2 items away and now it is fine.

I would like to create a rule saying “from this list, if the object is not a curve, get rid of it”.
I did not manage this, but I hope I will not have any point somewhere else than first and last item :smiley:

Thanks for your time

List.RemoveIfNot should do it :smiley:
(Together with a string containing something like DesignScript.Geometry.Curve)

Hi @Daan
Thansk a lot!
It worked :smiley:

I have one extra question maybe you can help me… I have another post but no one answered and I could not find a solution online

I am running Dynamo from Alias.
and in Dynamo I have big disply issue, the 3D background is jumping all the time :frowning:
I found online that Direct X must be up to date I did all of this, I did include dynamo to the Nvidia control panel as well nothing changes.
Did it already happened to you?


Hi @ClRo ,

I have only worked with (multiple versions of) Dynamo Sandbox, Dynamo Revit and Dynamo Civil 3D. I have never had this problem myself, maybe you could try reinstalling your Software alltogether and reupdate your DirectX (10, 11, 12). Other than that I have no clue what could cause this problem.