Geometry Fails in Dynamo Revit but Works Fine in Dynamo Sandbox


I am a beginner user of Dynamo. I was working in Dynamo Studio without turning it on through Revit. Just in straight way, through desktop. Now, when I try to start my Dynamo project through Revit, it occure many bugs in nodes. The first mistake in nodes looking like that:

When I open project through Revit it looks like that:

(This is my second, private account) When I open it straight through Dynamo Studio it looks like that:

I don’t have idea why it doesn’t want to make any surfaces.
Does anybody knows how to solve it? I can share my Dynamo file.

Please show your graph :slight_smile:

Unfortunately, I am at work right now and I forgot to take my project file with me. I can send it in the evening.


Here is a link, where I put my Dynamo project (as I am new user, I can’t attached a file)

It works well for me in Dynamo for Revit 1.3.
Wich version of dynamo Revit do you use ?

Dynamo Core
Dynamo Revit

Does it look well in Revit too? Could You pass me a link to Dynamo version which You have?

It will probably work for you with an update to Dynamo Revit 1.3.3.
I tested with Revit 2017.

For the moment you have no elements in Revit, just the “skeleton” but it looks good.

I can’t find this version. I can update to Dynamo 2.01. I have Revit 2018

Dynamo 2.0 syntax is a little bit different.

You can find the version 1.3.3 here :


Big thanks! I will install it and check if it works properly.

You’re welcome. Let me know if it solves your issue.

It didn’t help. Maybe the clue is that I have Revit 2018? I don’t have idea why it doesn’t work

How is your dynamo preview configured ?

In the same way like You. The problem starts in graph where bugs occure when I switch Dynamo through Revit. It doesn’t want to draw any surfaces.


I tried with another computer.
The graph fails with Revit 2018 and works well with Revit 2017. I don’t know why.

Revit 2018 :

Unfortunately I do not have 2017 to test on but can verify the same result as you in 2018.2… I think it might all be related to this part, can any of you verify the output of the list.create node in 2017? (Same output when using Sandbox btw)


Hi Jonathan,

The output in Revit 2017 :

And no error in the PolySurface.ByLoft node.