Issue with GeniusLoci Export to NWC node


I am new to Dynamo. I have seen few of my colleagues use it in the past but I never really tried it till now.

I have an ongoing task of exporting certain 3D views to Navis and I knew it could be done through dynamo. Thought I’d give it a shot . After going thorough some posts in this forum, I was able to figure it out. Added a prefix to filter out the views that need to be exported and used the GeniusLoci node (mentioned here so often) to export the views. Removed the prefix from the export’s name and gave the option to save it to a location. It ran well (Revit 2020, 21, 22) and I was able to export the views (w/o prefix) needed.

I wanted to add some UI and give the option of choosing which views ( from the filtered set) to export to the user. This is where I ran into some trouble. As you can see in the image, the MultipleInputform++ node from Data-shapes package shows the views that are selected but for some reason the “Export NWC in document” node doesn’t work now. When I start the run, I get the window with check boxes to select the views. I make the selections and hit “set values” . After this it just says “Run completed” and the directory is empty. I don’t even get a warning that there is something wrong/missing with this node. Not sure what is going on. I thought if the directory is not created beforehand it wouldn’t export, I created a new folder too but that didn’t work either.

I can’t upload my dynamo file as I’m a new user here so I’m adding any relevant info:


What am I doing wrong here? What do I need to change for it to run properly?

Hi @skandregula,

The output of the MultipleInputForm node is a list of list. Add a List.Flatten node after the collected views before the Export NWC node.

1 Like

That worked. Thanks a lot Alban!

Welcome to the forum!
This is very handy tool, I recently made one myself the same way. I love being able to export a bunch of views and walk away while it process.

1 Like

Yep, sometimes the exports are huge and time consuming. this definitely makes life easier.

Hi there – I’m having trouble with the same node, but it doesn’t seem to be the same issue. I’m simply not getting the correct output – I previously had the script setup in a different way, but the ‘Export NWC in Document’ node has always been there and worked before (last time used about a month ago). I’m now getting a result here that does not make sense to me – has anyone seen this before? ‘Result: T; Document: r’

No errors or issues, just not completing properly. What am I missing? TIA!


Hello try to feed in the views and for names use an element name after your filter by bool mask…next time just make a new topic as this one is solved…

1 Like

Hiya – thank you, I’ll go ahead and make a new topic, but just wanted to reply here on your suggestion as it didn’t work :frowning: Still getting the same result.

1 Like

I don’t think I’ve come across what you described. Once I figured out the issue in my original post I never had any trouble running that script. It has worked each time I ran it and I last ran it a few hours ago.

Sorry, I can’t be of help to you on this one.