Generative Design with Dynamo shows wrong results

Hey guys,
i’m fairly new to revit, dynamo and generative design and have run into some problems, of which i couldn’t find an answer to so far. Maybe you can help me.

So im trying to arrange a couple of objects inside a room i’ve created in revit using dynamo. Then using the generative design package i would like to optimize the layout of these objects. The implementation seems to work so far, however problems occur when i run the optimization. I get for some outputs simply a “*” and the room appeares empty instead of filled with the objects. However when i click “Open in Dynamo” the objects are actually placed and the outputs do have a value. So there seems to be some kind of problem in the optimizazion with the generative design tool.
I also tried to expand the populations size and have changed the study settings, but nothing worked.

Does anyone know anything, that could help me?
Thanks a lot in advance!



Are you using Remember Node?
In Generative Design, Revit-related Nodes cannot be used, so you need to use the Remember node to store Revit data.

Yes I have remember nodes for all revit imports. Do i also have to put these nodes behind excel imports?

And what about using constraints? The resulst also do not regard those.

It seems that there is no problem because it uses the Remember node for all Revit Imports.
I don’t think you need a Remember node for Excel Import.

Have you ever run your Dynamo program on Dynamo Core?
Programs that work with “Dynamo for Revit” may not work as expected with “Dynamo Core” (which is used by Generative Design).
You may be able to find the cause with Dynamo Core.
I was previously able to notice that the dataflow was corrupted due to a bad connection on the Remember node.


Open the graph in Dynamo, and set the inputs to the values which were used to produce the * result. This will confirm my suspicion that Generative Design has found an edge case you haven’t accounted for, which is throwing an error causing ‘null’ to be sent to the watch node. Could be something like a point at a parameter which isn’t on the surface causing geometry intersection to fail, or similar.

1 Like

so i have added remember nodes after every import (excel and revit) just to be sure. also i have tweeked my graph here and ther and now i don’t get the problem of no placed items anymore. not sure what the solution was though.
thanks a lot for your help guys!

1 Like

For some reason now i have the same error again. I’ve tried your suggestion, however while I get * in the Output overview of the Generative Design section, the outputs do have valid values when opend in Dynamo.
Do you have any other idea what could cause the problem?

Try a restart - your generative design might be in a bad state.

If that doesn’t fix it please post your DYN and associated files, including the rvt file, to this thread so the larger community (including the Generative Design development team) can help out.

Here you go: Dropbox - Dynamo files - Simplify your life

I hope you can understand what i’m trying to do, most of my annotations are in german. please feel free to ask otherwise. What i’m trying to do is place the elements in the room, try not to have them intersect with each other, the path or the wall trough penalties. Subsequently i’m trying to optimise the result by minimising transport and have objects with a certain mobility score placed close to walls.
However like previously stated i don’t get proper results from GD instead just * (see screenshot)

Thanks again for your help and anyone else who can help me out with this!

I couldn’t get results from your graph to run in Dynamo for Revit until i fixed this error:

Class names (ie: Dictionary, String, etc.) cannot be used as an input like this in Dynamo 2.6 and up (which I believe your Generative Design build is using).

Likely you need to install a Revit update to get the updated Dynamo build and expose this issue more readily - current build number is 2021.1.2?

1 Like

Thanks a lot, it works again!

I was still on build 2021.1.1 . So I’ve installed all available updates and renamed the Code Block, it was just for organization purposes anyway. Now the GD evaluation produces valid solutions again. Thanks so much!

1 Like