Generative Design "No Study Type Found"

Hi everybody, it’s the first time I write on the forum as I’ve always found in other discussions the answers to my questions.
I’m trying to create a study in Generative Design: the Generative Design Tool work correctly and shows me the path where the dependencies are saved but when I’ll try to create the study and I put the folder path the tool tells me that there aren’t study types in the folder.
I tried putting the.DIN file and the dependencies by themselves in another folder.
I also tried putting my study in the Autodesk demos folder, the tool sees Autodesk demos but not my studio.
I tried with Revit 2022 and Revit 2021.1 with Dynamo 2.10 following the instruction on the Autodesk troubleshoot but none of the solutions worked.
If someone had the same problem and came up with a solution, that would be great.
Meanwhile, I will try with Revit 2020. The last time I used it worked perfectly.

Thanks to anyone who has an idea or a solution for the problem.

FYI @nate.peters

Hi @Ale_Macchi - Can you post the Dynamo graph that you’re having problems with?

1 Like

Hi @nate.peters, I finally solved it by copying and pasting the script into a new dynamo file. Probably there was a problem with the original file.
My fault that I didn’t try the simplest solution first.

Can you share the graph which failed anyway? If not here than in a direct message to @nate.peters? He’s on the development team and getting files which fail in some way is really helpful for them to make a product which doesn’t fail. Thanks!

Dear all,
Actually, I am facing the same issue in Revit 2023 and Revit 2022.1. My script is not relying on any Revit data. I keep getting “No study types found” when I click on create a study in Dynamo. I have noticed that the required dependency folder has not been created. I tried removing some packages but didn’t solve the issue. I also tried to copy the script to another Dynamo file but it did not work (as suggested by @Ale_Macchi. This issue is happening for all my Dynamo scripts not only this one. Please find the Dynamo file attached and a screenshot. Hope we can find a solution. Thank you

Testing.dyn (159.4 KB)

FYI @LilliSmith

Select show graph status from extension menu…
then select graph type as generative design
Fix any problem appears ( as you need add some nodes to help your study)
Let me know if it worked >> :smiley: