First row in excel must be filled?

revit
excel
dynamo

#1

Hello,

When i was trying to run this script i figured that it only works when the first row (which it reads from the excel file) is filled.
If i don’t do that… The whole script will not work.
Is there a way to make sure this script will work all the time?
The problem focusses on the blue (on the top) area.


#2

Hi @jesse.heijtink

Screenshot is not clear. Drop here dyn and excel file here it will others who is trying to help you.


#3

I’m able to read an excel file without data in the first row. It’s likely something else.
Like KulKul said, a better image would be helpful. Zoom in until the nodes in your graph are legible then use the screenshot button in the top right corner of the Dynamo window.


#4

Without any clue about the nodes, I think that your nodes, pas the Read From Excel one, fail because of the fact that a node will generally fail if the first data it receives is a null.


#5

Sorry But i get the message that i cannot upload the Dyn File, because i am a new user. and i can only post 1 image at the time… so this will be 3 posts.
What i did is, I split the two parts. In my first message you can see how they belong together.
I also added a Excel image of what i am trying to put in the space parameters. So if i do not fill in “1” “2” “3” “4” “5” in the first row, I won’t get any result. If i do fill them in… I get Dynamo will fill all the spaces and do exactly what i asked for. My question is, how can i count on Dynamo filling in the right codes/numbers into the space parameter without prefilling the first row? I hope everything is readable now, let me know if you have any questions.


#6


#7