Fields in AutoCAD Table

Is there a way to use Dynamo to enter a Field into an AutoCAD table cell? I tried copy and pasting the string generated when making the field but no dice.

You can use the civil 3D toolkit (table category on the autocad shelf) :

You can access the data

I’m aware of the ability to access the data - but how would I go about entering a field into a cell with these tools?

I’ve tried using SetValueByRowColumn but cannot set the value as an AutoCAD field, only ordinary text.

Ah I see… In that case I cant think of any node so you will need to use python. There are some methods on the table class to interact with fields and you have the [field class]

1 Like

Wonder, @david_licona … how do I actually do to add these metods for classes in a script. Or maybe, even better, do you know a way for me to learn more about it?

ah ! unfortunately there aren’t many ressources out there… I’m waiting for @mzjensen AU’s class submission to get hopefully accepted this year :crossed_fingers:

some forum threads on the subject :

Frankly, my recommendation is learn the basics of python and object oriented programming, then see the wealth of examples in this forum to see how to interact with the APIs. Paolo’s example cited in those links is particularly good ! At the beginning its overwhelming just to even navigate the API Reference Guide, but practice gets you there. Start simple and work yourself up.

Finally, if by any chance you know spanish :


Thanks for the links, David.

FYI there are nodes in Camber v4.1.0 for working with Fields.


Hi mzjensen, is this available in 2011 C3D?

@Joel_Buenafe - no, Dynamo in Civil 3D is not available prior to 2020.

My bad, i was meant to type 2021. Apologies. I was trying hoping to use these nodes

Yes, they should work in 2021. Make sure you have the latest C3D updates installed.


Hi, any idea why i’m getting this? My C3D version is shown below as well.

Thanks again for your help.


You need to install the latest updates for Civil 3D 2021.

1 Like