Familyinstance.bypoint does not place familys at designated point

Hi,

I have been trying to make a script the places a familys, that i made, in the location of ventilation dampeners that need power. The script worked fine until today, when i tried to run it the script did not place the familys in the location of the dampener but near the project base point instead. Is this a bug or is something wrong in the script and how do i fix it? Thanks

ydk5xMwOOg

Is the damper location derived form the location of an element in a link? If so you’ll need to account for the link’s transform, as the values will be pulled from the link’s internal origin and ignore the link instance’s placement in a host project.

Hi, thanks for responding. I have used the BiMorph nodes to get the dampenes in the link model as shown under. I dont know how to transform the locations tho.

I foud out that i can place the familys in the correct position but its the second part of the script that causes issues. i checks if any of the dampeners in the link has chanced position and then moves them. the problem is when i want to place new familys then i get the right location in the “familyinstance.bycoordinats” node, ut then i try to get the location again to check if the dampeners have moved then it is set to zero.

Maybe this is caused by the same issue you described @JacobSmall?

Nothing in the ‘relocate’ section has any action that moves an element. Can you zoom in to this scale and export your workspace as an image so we can see the whole picture? The camera button in the top right corner will do this.

yes it has a “element.setlocation” node at the end. Here is the image couldnt send the PNG image it was to large so hope theis makes sense :slight_smile:

Hello, again. i dont think the problem is whit host locatiion. i tried to switch out the “getlocation” node for the BiMorph node and that will give me linked elements at host location, but the problem is still the same. when i try to place new familys it places them at the origen point @JacobSmall