Family Parameter not following the setparameter node value

Hi everyone,

Just want to ask, if anyone here experienced setparameter node value not encoding to a family parameter properly? I tried to cast the value as integer, string or float but it didn’t work.
In the screenshot i am supposed to input the value 2700, but when I run the script, the value becomes very large… tia ^^

This Problem is because of unit change
Dynamo unit is the units while opening the revit file
when you try changing the units after opening the dynamo then the unit will be set which you set while opening. Try closing both revit and dynamo. Open revit file, set unit which you wish and open dynamo file it will work

1 Like

hi bro @dineshsubramani ,

Thank you for your reply. I-tried the procedure that you described, but I still get the same output.

Do you think I need to use python script to convert units?

What did you try? Can you show an updated image? It should just be a mathematical conversion.

1 Like

Hi vbaac,
Fixing the project units before opening dynamo should work
if else try changing the units of Family File

again Fail alternatively try converting the units before setting the value

1 Like

Hi bros @dineshsubramani @Nick_Boyts

Since I cannot stop dynamo from converting the values, what I did is cancel out the multiplying factor by dividing the values by the said factor before feeding it to setparameter node. So in that way I get the value needed.

Thank you for helping ^^

1 Like