Family Insatnce by Point

#1

Hi all,
I’m trying to place piles in my Revit model using the FamilyInstanceByPoint node but for some reason Dynamo is reading the Z values of the points correctly.

I’m trying to place the piles directly underneath a number of capping beams but as you can see in the image, the piles go right through the capping beam. The placement points are derived from a line that runs along the bottom centre of each capping beam.



PlacePiles.dyn (42.2 KB)

If I run the script for a second time, the piles are then placed at the right height (below the capping beam) but I don’t really want to have to run the script twice.

Any ideas?

May thanks

0 Likes

#2

Hi,

Please add your graph and a picture of your graph with all the previews enabled under the nodes.

https://forum.dynamobim.com/t/how-to-get-help-on-the-dynamo-forums/4677

0 Likes

#3

Hi,
Sorry I had strip back my script as it had other nodes or UI that made it rather large. I have included screen shot and script on my original post.
Thanks

0 Likes

#4

For me, it works well on the first attempt. (Revit 2017)
Are you in automatic mode ?

0 Likes

#5

No, Im on manual mode and also working on Revit 2017

0 Likes

#6

http://dynamobim.org/forums/topic/place-a-face-based-family/

0 Likes

#7

Hi Alban,

just tried placing piles with dia. wider than the base of my capping beam, just like you’ve shown in your image, and it worked the first time i ran the script. I had a sneaky feeling that this might be the reason it worked for you the first time you ran the script. If you’d be so kind to try and use a beam that is wider than the dia. of the piles you are using, and see if my theory is right?

many thanks

0 Likes

#8

Unfortunately my pile family is not face based but thanks!

0 Likes

#9

Hi Renzo,

It can’t be the reason.
It is rather like a calculation was made after the piles were created and a node passthrough was missing somewhere, but I don’t see where for the moment.

0 Likes

#10

Hi @Renzoj14,

There is something strange in your Revit file. When I copy the pile and the Capping beam in another Revit projet, I haven’t to run twice your graph.

The solution will be to set the Height Offset once the piles are created.
Modify%20Heigt%20Offset

0 Likes