Extrude a toposurface/polysurface?


#1

For the company I work for, we do a lot of entertainment and animal exhibitions, which incorporates fake natural environments with personnel/staff rooms underneath. For example, a penguin exhibition that emulates rocks, stones, etc, in the form of a sloped terrain, and we have maintenance rooms underneath that the general public do not see. So when we create our construction drawings, and more specifically sections, we always fake that sloped terrain thickness with filled regions in Revit.

I know we can turn a toposurface into a polysurface, and I tried the extrude option after getting the polysurface but getting an error. Any ideas on how to make this work?

 

Thanks!

Toposurface extrude


#2

Have you considered turning your toposurface into a floor slab? This would give you the advantage of having actual building elements with material layers that are cuttable (i.e. create as many section views as you want on the fly). Also, it would allow you to have your walls extend to the bottom surfaces of those floor slabs. You’ll just need a floor slab that has the same boundaries as your topo and the tiniest amount of Dynamo nodes:

topo2


#3

Hi Andreas, many thanks for your suggestion! It sounds like a very reasonable solution, but I have tried it twice: it gets stuck while running in my PC (HP Z640 dual processor 32GB Ram, Intel Processor 2.4 GHz), and it does nothing in another machine I have tested (completed run with no warnings). How long it took for you to do it? I also wonder if I am missing one set of package or something?

I am using Dynamo 0.8.1 with Clockwork installed.

On a side note, I am also experiencing this problem of getting stuck with other experiments, so am not sure if the problem is the computer or not, but I have to say that only Dynamo is having this kind of issue. Revit works just fine.


#4

I guess it depends on the complexity of the toposurface. For this example I used the topo in the basic architctural sample model that ships with Revit and it took maybe a few seconds in Dynamo 0.7.5 - haven’t tested it in any of the new versions as I am still using 0.7.5 in production most of the time. Maybe you should try it on that model first, too. (Note that I trimmed the toposurface to fit the boundaries of the floor slab before I ran the Dynamo graph).


#5

I just tried it in 0.7.5 and it works wonderfully!! Many thanks Andreas!

You have made my day…


#6

Francisco - Seems like Andreas’ solution is the better way to go.

But, just wanted to point out the error in your definition

You were trying to extrude a polysurface by using the Curve.Extrude node and that was the issue.

While I’m not sure if you can extrude a polysurface, you could consider using Surface.Thicken one step earlier.

20150729-2

 

 


#7

Good point Vikram! Will give that a try and I might use that alternative for other purposes in the future. Thanks for pointing that out.

 
<h1 class=“yt watch-title-container” style=“color: #222222;”></h1>


#8

Hi Andreas,

i am trying this method from three days but its not working i am using that same nodes from clockworks , when i am giving run option in dynamo its deleting all elevation points at roof or floor.any ideas about this welcome.1


#9

Im back at this, keeps hanging for me also on a very small smaple. I just placed a few points manually