Exporting shape images to excel

Hi there,

I’ve been having some problems with exporting rebar schedules to excel for some time now.
Getting the data from the schedules and exporting it works fine, with the exception of exporting the shape image of the rebar shapes as an image. Right now it exports it as text.

Does anybody know of a way to export shape or type images to excel?

Hey,

Maybe try the bumblebee package? It might be that you can get this to work?

Hope that helps,

Mark

1 Like

Thank you for the response. I came across that node some time ago but could not for the life of me get it to work. It’s probably just a lack of experience holding me back so should have another go at it when I can.

1 Like

I had a quick look…

So, bumblebee is off looking for this file?

image
in packages\BumbleBee\extra

This file goes to look for protogeometry, to do this, it shortens the Dynamo version… You can open it with notepad and see that…

dynamoversion = str(dynamo.GetName().Version)[:3]

Unfortunately this outputs ‘2.0’ for me… whereas the dynamo team have named the actual folder ‘2’ image
so everything fails.

If you amend the line in that file to
dynamoversion = str(dynamo.GetName().Version)[:3][0]

It returns ‘2’ and works (at least for me, for this version)

Hopefully that helps.

Cheers,

Mark

1 Like

Thank you for your detailed response. I tried looking for the line in the file you mentioned but can’t find it, ctrl+F doesn’t find it either.

I tried creating a seperate dynamo to just simply embed the image and even though there are no errors shown and the output for the mebed image node is succes, it still does not embed the image into the specified excel file. (just an empty cell)

Hey, the line you’re looking for is in:

packages\BumbleBee\extra\Bumblebee.py

Could you confirm with a screen grab that that is where you are looking?

Thanks,

Mark

Hi,

This is the file I’m looking in. I scanned it three times manually and still didn’t find it so I really hope it’s not just me being stupid :sweat_smile:

For me it’s near the top :slight_smile:

Maybe it changed in your version?

Huh, really strange. Legitimately not there in my version

I popped over to Konrad’s github, copied the same code as you have over to my bumblebee.py file and the graph ran…

I think you might have to raise it with him, sorry…

Mark

Edit: you do have an open Excel file when you run it right?

I have the excel file open, but I’m running it from Dynamo for Revit. Maybe the problem is that I need to use sandbox or something?

Mine’s fine in Dynamo Revit…

Strange, I’ll try to take it up with Konrad as you suggested. Thanks anyway for all the effort and help!

1 Like