Export to Libre office

At the request of @Kulkul , I update an old discussion Microsoft Office (Excel) vs LibreOffice/OpenOffice

In response to @Dimitar_Venkov and @Yna_Db Yes the problem comes from lists that include element. But i have used the node string from object and it’s work for the most of them. But i have always this problem where parasitic data appear

But that’s strange because with the excel write to file i didn’t have this problem. And my list had also element in there.

@Konrad_K_Sobon No i didn’t try but i didn’t understand how use it …

Again thanks all for your help

You’re literally 99% there. It’s really simple.

Option 1:

Then when you open the file with LO use the following settings:

And you should get this:

Alternatively search for “change number format” in your start menu click on the “Additional Settings…” in the bottom right corner and make sure that the decimal symbol is not a comma. That way you can also use the built-in CSV writer, without getting “parasitic” data:

@Konrad_K_Sobon Archi-lab has some great CSV reading nodes, but no writing nodes as of this moment. Maybe that could be a nice future addition? :slight_smile:

4 Likes

I used the option 1 and It works ! Thanks a lot @Dimitar_Venkov .