Export surface from Revit to Civil 3D

Hello, everyone.

Are there any nodes in Revit that allows a surface or any similar element to be exported as a file possible to be opened as a surface in Civil 3D (i.e. .xml file)? I’m a Civil 3D specialist, don’t know much about workflows in Revit.

Thanks in advance!

Hi @ricaerrido

Check out CivilConnection package

2 Likes

@Kulkul thank you! As simple as it is, I do appreciate your attention in giving me directions.

Hello, @Kulkul
I’ve studied some of the nodes but I couldn’t understand how the ouput of RevitUtils.ExportXML works. Do I need to work with C3D and Revit at the same time?

I think the answer is yes. Most of the nodes in CivilConnection rely on an open connection to Civil 3D using the CivilApplication node.

I’m not sure that RevitUtils.ExportXML will work for what you want. Do you need to export/import? If you use the CivilDocument.AddTINSurfaceByPoints node, then you can create the TIN surface directly.

3 Likes

Great, thank you!

As I started studying the nodes, the CivilApplication.CivilApplication with the CivilApplication.GetDocumentByName didn’t find the opened .dwg. Does the name (string) need to have something different? Can you think of any other problem? I’m running Civil 3D 2022, Revit 2022 and Dynamo in Revit.

At first my intention is to import a TIN Surface, and then export this topograph surface from Revit to Civil 3D as a TIN Surface.

I don’t think it’s been updated to run with the 2022 versions yet.

@Paolo_Emilio_Serra1

I’ve just tested in 2021 Civil and Revit, still the same issue.

Did you include “.dwg” at the end of the file name in the string input?

Yes. I also renamed the file to not use special caracters and tried to use the full path, but later I saw in the .svg that it’s just “.dwg”, and no success.

Any chance you can upload a screenshot or GIF recording?

Sure!
By the way, thank you for the help!

This is a screenshot from my .dyn file (sorry for any mistake, I’m quite a beginner with Dynamo)

The node CivilApplication.CivilApplication shows the following message:

Warning: CivilApplication…ctor operation failed.
Object reference not set to an instance of an object.

I draw a topograph surface on Revit (shuffle points, just to simulate) and I am trying to export to a .dwg file opened in C3D named as TESTE.dwg

Have you installed CivilPython?

Yes, I have
Is there a way to check if it’s working well?

There should be a log file in your user temp folder. Anything strange in there?

There are some debug.log files (i.e. aria-debug-16352.log, all empy when opened with Notes) and a CivilConnection_temp.log with the following text:

[12/05/2021 12:35:32] CivilApplication.CivilApplication started…
[12/05/2021 12:35:32] GetApplication started…
[12/05/2021 12:35:32] GetApplication completed.

@mzjensen Issue is solved. I was using Revit 2021 but my Civil Connection version was 2020.

Thanks @Kulkul for solving my problem on my pc. You’re life Saver :slight_smile:

1 Like