Excel.ReadFromFile operation failed for one user

dynamo

#1

Hi all,

I’m experiencing issues with the Excel.ReadFromFile node.
It seems to work on most computers, but fails to run on one computer.

This is what it should look like:

This is what it looks like on the computer that fails to run the script:


“Toegang gewijgerd” means Acces denied
In both cases: same office version (2016) and script was run in Revit 2018.3

Any idea’s ?

Files:
TestExcelReadFromFile.DYN (4.0 KB)

View dupliceren.xlsx (8.1 KB)


#2

Can the use whom is failing open the XLS directly? Access Denied is a permission issue potentially to the actual file.


#3

Yes he can open the file directly. We also tried to run script with the file saved on a network and local location. both cases failed


#4

Perhaps doing a repair on Office may work. What version of Revit and Dynamo are you using?


#5

Revit 2018.3 and Microsoft Excel 2016 (16.0.11029.20045) 32-bits
This is the same as on the computer where the script does run.

We also tried to repair Office, didnt work


#6

Is there any chances that path name of the network might differ on different computers? For an example one is built on “Z:” but the other computer has it like “D:” I know it is odd but the only thing comes to my mind is this.


#7

No thats not it, file location is not predefined. Its chosen per user.


#8

Uninstall office, clean out the registry of all office keys, and reinstall office.

See if that clears it up for you.

If not, it may be an AV/ASW security thing. Confirm all systems have the same setup and settings for each on that front.