Error with dynamo script that pushes space parameter to mechanical eqiuipment parameter

I am trying to use this script to copy a space ID from the space to all mechanical equipment in the space, but i am getting 2 errors with my script. The code blocks contains the parameters i am writing to and from

I am very new to using dynamo, so don’t hesitate to point out my mistakes

the errors I am getting:


Can you provide an image with the node preview showing the results for each one?

@SeanP I have tweaked the script a bit since i posted, but here is what i got now:

The issue you are having is that the Space is not being determined for the instances.

Without the spaces, then none of the rest will work. If you schedule the instance in Revit, can you get the Spaces they belong in to show up?

@SeanP I can’t find any parameters when i schedule it that determines which space it lies within.

I tried with a plugin (NTI tools) to use its parameter copy, but what i can usually do there is not available in this project for some reason (usually you can copy from [Space: “any parameter a space has”] to any parameter a family category you have selected has.

Hello are you sure the component intersect the space ?

@sovitek I have double checked some of them, and all of the ones i have checked are inside the space:

try find the locationpoint and try with node "is point in space

@sovitek I tried but couldnt get a specific space.

Does this mean that my dynamo cant find any spaces?

Look like that try to disconnect and Connect again and maybe restart the graph if you are sure you had Spaces In the model

1 Like

Are the spaces in the current model, or a linked model? What does the warning say when you try and collect the Spaces?